Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-12-2012, 01:51 PM   #1
dki114
Scooby Newbie
 
Member#: 331997
Join Date: Sep 2012
Location: Jacksonville, FL
Vehicle:
2001 Impreza L

Subaru Stars HI every1!! > subaru fan here <

Got a few subarus here myself.

first my EJ22 96 legacy outback AWD auto still have it today....

( i was replacing rotors and pads on this one )



Then recently a week ago i picked up a AWD 2001 impreza wagon 5 speed project!!! well it runs but dosent.
( First pic! i got very excited as you can tell and drew over the hood )


Recently found a couple usefull service manuals & diagrams to help get started on this new project i have. MORE pics shall be coming soon.
* Registered users of the site do not see these ads.
dki114 is offline   Reply With Quote
Old 03-14-2013, 12:25 AM   #2
dki114
Scooby Newbie
 
Member#: 331997
Join Date: Sep 2012
Location: Jacksonville, FL
Vehicle:
2001 Impreza L

Subaru Stars N00B update

FIRST, I would like to give big thank you! to www.nasioc.com forums & www.rs25.com for the great guides, pictures and information they have provided me with online... A+


last year ive got hands on a 99-01 impreza l 5 speed with horrible banging & knocking noises from the transmission, Ive only self worked on small Hondas & Acuras long time ago so im new to Subarus, & im not aware what might have went wrong with this picture.
+ I also noticed a tiny leak coming from the middle of this vehicle causing light white smoke( from under the car ). someone plz HELP! PL0X?





ANYWAYS long story short. I followed some guides on the forums then finally pulled out the transmission from the EJ22 and happens to be mines has A TAIL!





Ive tried separating the propeller shaft / drive shaft from transmission but just wont come out is there a way to detach that piece?


Last edited by dki114; 03-16-2013 at 01:49 AM.
dki114 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.