Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-12-2012, 03:33 PM   #1
Pickler
Scooby Newbie
 
Member#: 301247
Join Date: Nov 2011
Location: Toronto
Vehicle:
09 Impreza 2.5i MT
White

Default Weird rumbling noise under 2500rpm (video)

my engine is making funny sound when under load below 2500rpm. it's sort of a rumbling noise (almost a rattle but its not) and it resonates through the cabin but i feel it coming from the engine. it happens specially in summer drives with humid hot weather. anybody can help me diagnose the problem, if there is one?

(turn up the volume and you'll hear the weird rumble at or below 2000rpm only, specially in 4th gear or after upshifts)

other symptoms:
- car feels weak
- poor throttle response
* Registered users of the site do not see these ads.

Last edited by Pickler; 09-12-2012 at 03:46 PM.
Pickler is offline   Reply With Quote
Old 09-13-2012, 02:27 AM   #2
Sleeper_RS
Scooby Newbie
 
Member#: 305380
Join Date: Dec 2011
Default

Hmm idk man. Check all fluids, and spark plugs for any signs of lean/rich. That's weird
Sleeper_RS is offline   Reply With Quote
Old 09-13-2012, 02:28 AM   #3
Sleeper_RS
Scooby Newbie
 
Member#: 305380
Join Date: Dec 2011
Default

What do u drive?
Sleeper_RS is offline   Reply With Quote
Old 09-13-2012, 02:34 AM   #4
lavid2002
Scooby Specialist
 
Member#: 226864
Join Date: Oct 2009
Location: southern NJ
Vehicle:
2005 PSM WRX
18.5lb. 93 oct, DP, UP

Default

Check the plugs on it, any recent work done? How long has the car been like this? Long enough for a C.E.L. to come up?

You're almost at 60k so it wouldn't hurt for you to toss some new plugs in even if the old ones don't give you any useful info.

Also, try some MAF cleaner. How does the car idle?
lavid2002 is offline   Reply With Quote
Old 09-13-2012, 03:28 AM   #5
MarcoPolo360
Scooby Newbie
 
Member#: 265006
Join Date: Nov 2010
Chapter/Region: E. Canada
Location: London, Ontario
Vehicle:
2011 2.5i 5MT
World Rally Blue

Default

Quote:
Originally Posted by Sleeper_RS View Post
What do u drive?
Look at his profile.
MarcoPolo360 is offline   Reply With Quote
Old 09-13-2012, 09:42 AM   #6
FPS_Bloodline
Scooby Newbie
 
Member#: 314552
Join Date: Mar 2012
Chapter/Region: NESIC
Location: Northford, Connecticut
Vehicle:
2011 Impreza
Spark Sliver

Default

mine makes the same sound i have under 30k on it


i think its normal no codes on my side
FPS_Bloodline is offline   Reply With Quote
Old 09-14-2012, 05:07 PM   #7
Pickler
Scooby Newbie
 
Member#: 301247
Join Date: Nov 2011
Location: Toronto
Vehicle:
09 Impreza 2.5i MT
White

Default

yea i had a 05 2.5i driver also saying that their engine makes the same noise. im wondering if this is a widespread problem or just a normal sound. in any case my dealership charged me $70 to install clamps to secure the exhaust on the heatshield. they claimed warranty doesnt cover this. of course this didnt solve anything. fuel consumption has gone up too in the city.
Pickler is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.