Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-14-2012, 10:02 PM   #1
03.dub.r.x
Scooby Specialist
 
Member#: 307997
Join Date: Jan 2012
Chapter/Region: SWIC
Location: Phoenix
Vehicle:
1996 Impreza
Glacier White (230)

Default Little Help Please

My right side is squeeking. when i press the break at low speeds. also ebrake light tends to light on and off
* Registered users of the site do not see these ads.
03.dub.r.x is offline   Reply With Quote
Old 09-14-2012, 11:32 PM   #2
FastS2k
Scooby Specialist
 
Member#: 59577
Join Date: Apr 2004
Chapter/Region: SWIC
Location: N. Central PHX
Vehicle:
04 fxt notansti
s2000 reallynotthatfast

Default

Quote:
Originally Posted by 03.dub.r.x View Post
My right side is squeeking. when i press the break at low speeds. also ebrake light tends to light on and off
"Ebrake" light could be low brake fluid, check it. Squeak could be time for new pads or maybe a rock caught in the pad.
FastS2k is offline   Reply With Quote
Old 09-14-2012, 11:42 PM   #3
WRX357
Scooby Specialist
 
Member#: 224249
Join Date: Sep 2009
Chapter/Region: SWIC
Location: Phx, AZ
Vehicle:
2002 Subiworx built/
Soulless tuned Bugeye

Default

You need a new set of pre owned modded injectors. That'll fix just about any problem on your wrx including the current problem you're having. And you're in luck, I just happen to have a set..
WRX357 is offline   Reply With Quote
Old 09-14-2012, 11:48 PM   #4
03.dub.r.x
Scooby Specialist
 
Member#: 307997
Join Date: Jan 2012
Chapter/Region: SWIC
Location: Phoenix
Vehicle:
1996 Impreza
Glacier White (230)

Default

thanks S2K but thats odd only on 1 wheel?

hey jared you should stop by and i think ur ryte
03.dub.r.x is offline   Reply With Quote
Old 09-14-2012, 11:53 PM   #5
FastS2k
Scooby Specialist
 
Member#: 59577
Join Date: Apr 2004
Chapter/Region: SWIC
Location: N. Central PHX
Vehicle:
04 fxt notansti
s2000 reallynotthatfast

Default

Quote:
Originally Posted by 03.dub.r.x View Post
thanks S2K but thats odd only on 1 wheel?

hey jared you should stop by and i think ur ryte
Brake pads can wear at different rates depending on the situation. You could have a sticking caliper or like I said, a rock somewhere in the brake system. It is only squeaking when you brake right?
FastS2k is offline   Reply With Quote
Old 09-15-2012, 12:04 AM   #6
03.dub.r.x
Scooby Specialist
 
Member#: 307997
Join Date: Jan 2012
Chapter/Region: SWIC
Location: Phoenix
Vehicle:
1996 Impreza
Glacier White (230)

Default

yeah man or when im going really slow
03.dub.r.x is offline   Reply With Quote
Old 09-15-2012, 12:11 AM   #7
FastS2k
Scooby Specialist
 
Member#: 59577
Join Date: Apr 2004
Chapter/Region: SWIC
Location: N. Central PHX
Vehicle:
04 fxt notansti
s2000 reallynotthatfast

Default

Did you check the fluid yet? Could also explain the brake light. As your pads wear, the calipers adjust and the fluid lowers.
FastS2k is offline   Reply With Quote
Old 09-15-2012, 01:56 AM   #8
03.dub.r.x
Scooby Specialist
 
Member#: 307997
Join Date: Jan 2012
Chapter/Region: SWIC
Location: Phoenix
Vehicle:
1996 Impreza
Glacier White (230)

Default

Quote:
Originally Posted by FastS2k
Did you check the fluid yet? Could also explain the brake light. As your pads wear, the calipers adjust and the fluid lowers.
was the pads sor thanks man
03.dub.r.x is offline   Reply With Quote
Old 09-15-2012, 01:59 AM   #9
WRX357
Scooby Specialist
 
Member#: 224249
Join Date: Sep 2009
Chapter/Region: SWIC
Location: Phx, AZ
Vehicle:
2002 Subiworx built/
Soulless tuned Bugeye

Default

Quote:
Originally Posted by 03.dub.r.x

was the pads sor thanks man
I could help you replace pads if you need it.
WRX357 is offline   Reply With Quote
Old 09-15-2012, 02:01 AM   #10
03.dub.r.x
Scooby Specialist
 
Member#: 307997
Join Date: Jan 2012
Chapter/Region: SWIC
Location: Phoenix
Vehicle:
1996 Impreza
Glacier White (230)

Default

Quote:
Originally Posted by WRX357

I could help you replace pads if you need it.
come on over and bring those injectors im feelin fortunate tonight
03.dub.r.x is offline   Reply With Quote
Old 09-15-2012, 09:09 AM   #11
WRX357
Scooby Specialist
 
Member#: 224249
Join Date: Sep 2009
Chapter/Region: SWIC
Location: Phx, AZ
Vehicle:
2002 Subiworx built/
Soulless tuned Bugeye

Default

Dang. I freakin passed out after I wrote that last post.
WRX357 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.