Welcome to the North American Subaru Impreza Owners Club Friday February 12, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-24-2012, 01:41 AM   #1
crash60068
Scooby Specialist
 
Member#: 209218
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Park Ridge
Vehicle:
2005 WRB WRX 4EAT
93 MR2, 2008 Yaris

Default flickering/rattling sound from turbo area with video

I got this clicking/rattling sound that comes around 3k then stops when i let off the gas. The sound is like when you roll your tongue. It drives perfectly normal boost feels normal and no power lost.

There is NO heat shield by the turbo and I got a cattless exhaust

you it hear after the :20 sec mark



* Registered users of the site do not see these ads.

Last edited by crash60068; 10-24-2012 at 01:54 AM.
crash60068 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-01-2012, 12:26 AM   #2
crash60068
Scooby Specialist
 
Member#: 209218
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Park Ridge
Vehicle:
2005 WRB WRX 4EAT
93 MR2, 2008 Yaris

Default

anyone know???
crash60068 is offline   Reply With Quote
Old 11-01-2012, 10:12 PM   #3
paukert11
Scooby Newbie
 
Member#: 327666
Join Date: Jul 2012
Chapter/Region: SCIC
Location: El Segundo
Vehicle:
02 slow psmwagon

Default

Turn off your radar detector or what ever the beeping sound is and re do the video.
paukert11 is offline   Reply With Quote
Old 11-02-2012, 03:06 AM   #4
crash60068
Scooby Specialist
 
Member#: 209218
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Park Ridge
Vehicle:
2005 WRB WRX 4EAT
93 MR2, 2008 Yaris

Default

Yea that was the battery almost about to die.
crash60068 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.