Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-25-2012, 10:13 AM   #1
kay95
Scooby Specialist
 
Member#: 45494
Join Date: Oct 2003
Location: glen rock, pa
Vehicle:
95 impreza L awd
green

Default td05 wastegate pressure

Well what is the stock pressure supposed to be because I took mine apart to port it and now I see 15-16# and spiking to 18# then a bad fluctuation. Is my wastegate arm too tight?
* Registered users of the site do not see these ads.
kay95 is offline   Reply With Quote
Old 09-25-2012, 12:20 PM   #2
TommyAtomic
Scooby Newbie
 
Member#: 257043
Join Date: Sep 2010
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
1993 JDM WRX Wagon
Black

Default

Quote:
Originally Posted by kay95 View Post
Well what is the stock pressure supposed to be because I took mine apart to port it and now I see 15-16# and spiking to 18# then a bad fluctuation. Is my wastegate arm too tight?
Is your wastegate too tight? Hmmm.... Did you tighten it?

Once removed from your engine the turbo can be easily disassembled without adjusting the wastegate pressure. So this would have to be something done intentionally. So did you tighten it? Also what kind of boost control are you using? Factory boost control? MBC? Aftermarket EBC with programmable controller? Did you hooked up the vacuum lines to the turbo correctly when you reinstalled it? Do you have a vacuum leak somewhere?
TommyAtomic is offline   Reply With Quote
Old 09-25-2012, 12:36 PM   #3
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

~8psi
eg33GC is online now   Reply With Quote
Old 09-25-2012, 12:44 PM   #4
kay95
Scooby Specialist
 
Member#: 45494
Join Date: Oct 2003
Location: glen rock, pa
Vehicle:
95 impreza L awd
green

Default

Well I guess it would help to know that I am running MS2 without a BCS. That 16# is straight wastegate pressure. I have a hose going from the nipple right to the wastegate.

I dont know why I took it apart that way. I took the arm end off and forgot how much tension to put back on it. I put alot on it when I put it back together. If I remember right I had to pull the diaphraghm arm about 3/16" or so to get it on the flapper arm. I am starting to think that is why too much.

I just wondered because I cant get it to run right at full throttle because when I look at my logs the boost fluctuation is causing accel/decel and overrun fuel cut. Which is the only thing keeping me from taking it to redline WOT. I can go to redline at part throttle and make 12-13#. From what I have been reading that shouldnt happen.
kay95 is offline   Reply With Quote
Old 09-25-2012, 12:49 PM   #5
kay95
Scooby Specialist
 
Member#: 45494
Join Date: Oct 2003
Location: glen rock, pa
Vehicle:
95 impreza L awd
green

Default

Quote:
Originally Posted by eg33GC View Post
~8psi
Well damn I guess it is a bit too tight then. I will have to back it off when I get back home in about 4 months.
kay95 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.