Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-25-2012, 12:05 AM   #1
hipower
Scooby Newbie
 
Member#: 155756
Join Date: Aug 2007
Chapter/Region: VIC
Location: abbotsford b.c
Vehicle:
369 tribeca 7 pass
vf34wrx,06 sti,08cbr600rr

Default check engine and cruise control light on

today my wife was driving the tribeca around and then suddenly the car studdered then the cruise control,check engine and the oil temp light turned on so she parked the car for a couple hours and then turned it back on but the cruise control light and check engine was still on but the oil temp didnt turn back on.So she drove the car home slowly.When she got home i checked the oil dip stick and it was empty so i put in a litre and a half and it was back to full,i notice in the middle of the oil cap threads the oil was burnt.Taking the car to dealer tommorrow but was just wondering what u guy think should i be worried.Car drives fine,no strange noises or leaking any thing just worried cause the the oil underneath the oil cap is burnt and the oil temp was on
* Registered users of the site do not see these ads.

Last edited by hipower; 09-25-2012 at 02:45 AM.
hipower is offline   Reply With Quote
Old 09-25-2012, 02:16 AM   #2
notjustforshow
Scooby Specialist
 
Member#: 143277
Join Date: Mar 2007
Chapter/Region: VIC
Location: Richmond
Vehicle:
05 STI PPP OBP
1098, Z1000

Default

Maybe somehow checking the code before going would help?

Going in blind may end up costing unnecessary dollars.
notjustforshow is offline   Reply With Quote
Old 09-25-2012, 02:18 AM   #3
hipower
Scooby Newbie
 
Member#: 155756
Join Date: Aug 2007
Chapter/Region: VIC
Location: abbotsford b.c
Vehicle:
369 tribeca 7 pass
vf34wrx,06 sti,08cbr600rr

Default

it still under warrenty
hipower is offline   Reply With Quote
Old 09-25-2012, 03:11 AM   #4
notjustforshow
Scooby Specialist
 
Member#: 143277
Join Date: Mar 2007
Chapter/Region: VIC
Location: Richmond
Vehicle:
05 STI PPP OBP
1098, Z1000

Default

Warranty or not, I still think it is a good idea to get the code pulled beforehand. If you have time to do this, it may save you some money, should they say the potential repair is not covered by warranty.

You had to add oil, approximately 1.5L in order to get the level into the dipstick range. The remaining cruise control light and cel indicates that the car thinks it is not safe to go on the highway. Something is up, and they may try to say it is not covered because of "supposed" lack of maintenance, so this is why knowing beforehand is a good idea. I don't know if I would clear the code before taking it to the dealer.

For wrx and wrx sti, (2002-2007 average of 50k Miles) the majority of oil pressure light warnings were for broken oil-pickup iirc. Not sure about the other cars.
notjustforshow is offline   Reply With Quote
Old 09-25-2012, 03:37 AM   #5
DIGGYGV8
Scooby Specialist
 
Member#: 313558
Join Date: Mar 2012
Chapter/Region: VIC
Location: Burnaby
Vehicle:
2011 STi Sedan
SWP

Default

Check engine + cruise + traction (if you have) is "limp mode"

Anything wrong with the car, it will stutter and keep you in that mode till then.

Best check it out, but it seems it may have died with oil starvation. Hope it goes well.
DIGGYGV8 is offline   Reply With Quote
Old 09-25-2012, 08:06 AM   #6
ofspunk7
Scooby Specialist
 
Member#: 249401
Join Date: Jun 2010
Location: Nord' St Paul
Vehicle:
2005 LGT and 91 MX5

Default

Check the code at a local auto parts store for free.


Check your oil more often!
ofspunk7 is offline   Reply With Quote
Old 09-26-2012, 02:57 AM   #7
hipower
Scooby Newbie
 
Member#: 155756
Join Date: Aug 2007
Chapter/Region: VIC
Location: abbotsford b.c
Vehicle:
369 tribeca 7 pass
vf34wrx,06 sti,08cbr600rr

Default

good news just got the suv back from the subaru dealership,the check engine and cruise control lights where cause from the automatic transmission shift solenoid needing to be updated.Had them do a hot engine flush and new synthetic oil change,everything seems fine and they said they didnt find anything else wrong
hipower is offline   Reply With Quote
Old 09-26-2012, 03:04 AM   #8
hipower
Scooby Newbie
 
Member#: 155756
Join Date: Aug 2007
Chapter/Region: VIC
Location: abbotsford b.c
Vehicle:
369 tribeca 7 pass
vf34wrx,06 sti,08cbr600rr

Default

Quote:
Originally Posted by DIGGYGV8 View Post
Check engine + cruise + traction (if you have) is "limp mode"

Anything wrong with the car, it will stutter and keep you in that mode till then.
only stutter for a second when the lights turned on after that it drove fine just the lights where on

Best check it out, but it seems it may have died with oil starvation. Hope it goes well.

[/quote] the suv drove fine it didnt die just the check engine light.the cruise control, and my drive indecator turned off
hipower is offline   Reply With Quote
Old 09-30-2012, 05:07 PM   #9
WrxJedi
Scooby Newbie
 
Member#: 333776
Join Date: Sep 2012
Default Smog Pump

Codes basically are saying your smog pump is out.
WrxJedi is offline   Reply With Quote
Old 10-01-2012, 12:51 PM   #10
2010 WRX Limited
Scooby Specialist
 
Member#: 217458
Join Date: Jul 2009
Chapter/Region: VIC
Location: Langley BC
Vehicle:
2010 WRX Limited

Default

This is some awesome armchair mechanics going on here.

Here's what I think happened: Engine is shot, car is worthless. Bring it by my house and I won't charge you to get rid of it. hahaha

Good to hear that it's fine, I wouldn't sweat the low oil thing too much, the difference between off the dipstick and full is only 1.5L.
2010 WRX Limited is offline   Reply With Quote
Old 10-01-2012, 04:20 PM   #11
Jeff54
Scooby Specialist
 
Member#: 129503
Join Date: Oct 2006
Chapter/Region: VIC
Location: reppin fort langleeey
Vehicle:
2002 It's resting
6 > 4?

Default

I've seen this before. The car is possessed....it's haunted by demons...but you're lucky i found you...i can perform an exorcism on the car for a case of beer.....true story....
Jeff54 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:10 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.