Welcome to the North American Subaru Impreza Owners Club Thursday October 27, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 10-02-2012, 09:26 PM   #1
Alaskan EJ20
Scooby Specialist
Member#: 160040
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchortown
2002 Bugi / 1993 L
Symmetry Tuning

Default car dies coming off throttle..........

car keep stalling and dieing when coming off throttle, mainly if im cruising around 2000-3000 and come off the throttle it dies. Idle is set to 700 and its a newly built longblock with sharp cams and hard springs. would raising the idle correct this or messing with tip in?? thanks ahead of time for the help.
* Registered users of the site do not see these ads.
Alaskan EJ20 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-04-2012, 10:58 AM   #2
Scooby Specialist
Member#: 212154
Join Date: May 2009
Chapter/Region: South East
Location: fast performance tuning
02 billet crank
pauter rods, pt5857, E85


I'm going to guess that you have a lightweight flywheel also? If your fueling is off with the cams it will cause a stall. If all fueling is good and you have a light flywheel you will need to raise the rpm threshold for cutting the injectors back on once you let off the throttle. You could just have a dirty iacv. Try raising the idle to 1000 rpm. If it doesn't help then one of the above will fix your problem.
fastblueufo is offline   Reply With Quote
Old 10-04-2012, 11:18 AM   #3
the suicidal eggroll
Scooby Guru
Member#: 51961
Join Date: Jan 2004
Chapter/Region: RMIC
Location: Broomfield, CO
2005 STi
2012 WRX


I've heard that some DBC cars need to have a small hold drilled in the throttle plate after installing large cams because the IACV just can't flow enough air to catch it properly at idle. Just rumor though. You may also try raising your idle up a couple hundred RPM.
the suicidal eggroll is offline   Reply With Quote
Old 10-05-2012, 09:13 PM   #4
Scooby Specialist
Member#: 59837
Join Date: Apr 2004
Chapter/Region: SWIC
Location: Nor Cal
2004 Spec-C Type RA
What MAF? -Speed Density!


You could also tighten the set screw on the throttle to slightly kick open the plate rather than drill it.
lukeskywrx is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:28 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.