Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-08-2012, 07:15 PM   #1
dacib
Scooby Newbie
 
Member#: 307828
Join Date: Jan 2012
Default Timing belt

The other day I replaced my radiator and since I had it out I took the timing belt cover on the passenger side off to see if everything is fine with the timing belt. The belt looked in perfect condition but it felt a little loose. I couldn't take the driver side cover off because 2 of the screws are rotating but are not coming out (common problem) to see if the tensioner is ok. The belt and all the idlers and tensioner were changed 6 months ago. Is this normal or my tensioner is bad?

By the way it's a 2004 WRX.
* Registered users of the site do not see these ads.
dacib is offline   Reply With Quote
Old 10-08-2012, 07:23 PM   #2
jaredperry
Scooby Specialist
 
Member#: 170928
Join Date: Feb 2008
Chapter/Region: SCIC
Location: Eight Oh Five
Vehicle:
'07 STi / '02 WRX
So Cali FL4T F4 #36

Default

How many miles on this timing belt?

How much vertical play? Is it about 1/4" vertical or well over 1/2"?
jaredperry is offline   Reply With Quote
Old 10-08-2012, 07:34 PM   #3
dacib
Scooby Newbie
 
Member#: 307828
Join Date: Jan 2012
Default

I put almost 10k miles on this belt. The play is about 1/4".
dacib is offline   Reply With Quote
Old 10-08-2012, 07:37 PM   #4
jaredperry
Scooby Specialist
 
Member#: 170928
Join Date: Feb 2008
Chapter/Region: SCIC
Location: Eight Oh Five
Vehicle:
'07 STi / '02 WRX
So Cali FL4T F4 #36

Default

That specified amount of play is normal
jaredperry is offline   Reply With Quote
Old 10-08-2012, 07:57 PM   #5
dacib
Scooby Newbie
 
Member#: 307828
Join Date: Jan 2012
Default

I thought so since it's on the other side of the tensioner. Thank you.
dacib is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.