Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-06-2012, 01:49 PM   #1
Mr Wrex
Scooby Specialist
 
Member#: 332887
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Orange County, NY
Vehicle:
2012 WRX stage 2+
DGM (sedan)

Default BPV hose fell off...

Just installed my Process West TMIC and a new BPV, then went to take it for a test drive. My car started to idle roughly and give error codes for all 4 cylinders misfiring, so I checked under the hood to see what hoses I forgot to connect. It seems that I accidentally pulled the BPV hose a wee bit too hard when connecting it and I had pulled it out from the other nipple it connects to...

Anyone know where that other connection is supposed to go to?
* Registered users of the site do not see these ads.
Mr Wrex is offline   Reply With Quote
Old 10-06-2012, 03:39 PM   #2
Navendra94
Scooby Specialist
 
Member#: 327495
Join Date: Jul 2012
Chapter/Region: Tri-State
Location: Ozone Park, Queens, New York
Vehicle:
2012 Impreza WRX 5DR
Plasma Blue

Default

WTF?!

-BUMP- For this guy's sake.
Navendra94 is offline   Reply With Quote
Old 10-06-2012, 04:42 PM   #3
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

The BPV hose connects to the turbo inlet right before the turbo and again on the BPV obviously.
HinshawWRX is offline   Reply With Quote
Old 10-06-2012, 05:13 PM   #4
Mr Wrex
Scooby Specialist
 
Member#: 332887
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Orange County, NY
Vehicle:
2012 WRX stage 2+
DGM (sedan)

Default

Quote:
Originally Posted by HinshawWRX View Post
The BPV hose connects to the turbo inlet right before the turbo and again on the BPV obviously.
I actually found out where it went to and it was on the back of the intake manifold. So glad I fixed it... my car was misfiring like mad
Mr Wrex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.