Welcome to the North American Subaru Impreza Owners Club Monday August 31, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-09-2012, 05:07 PM   #1
t_wrx
Scooby Newbie
 
Member#: 198217
Join Date: Dec 2008
Chapter/Region: SWIC
Location: Tempe
Vehicle:
2005 WRX
CGM never looks dirty!

Default squeaking front strut?

Hi everyone, I was hoping to get some other opinions in identifying a squeaking that just recently started coming from my front left strut (driver's side) whenever I go over speed bumps faster than 5 mph. It sounds like a squeaky toy
<-excuse the random baby but that noise is what it sounds like It only occurs when I go over bumps or dips in the road, it squeaks once as my strut compresses and squeaks once more as the strut decompresses, but when I go over a bump at a slow crawl there is no sound

I installed Dspecs/Tanabe GF210's (05 spec 326F/246R) 2 weeks ago and I did not experience any squeaking or odd noises for a week. Then after driving my car around town and parking it the next day it started squeaking. Now the only thing that I changed inbetween was changing my tire pressures to 37F and 35R (later changed the pressures to be even all around and the noise is still there)

The squeaking only happens like I said, when my front left strut goes over a speed bump or over a dip, so I think it may have something to do with the strut/spring...


My mods (I have an 05 wrx w/105k miles)
-new tokico dspec/tanabegf210 (05 spec)
-stock front sway/endlinks
-group n tophat front

Let me add also that I did NOT cut my stock bumpstops, and the springs have the plastic spring silencer sleeves on them. Also, when i installed my front struts I followed the order (tophat, washer, metal dustcover, bumpstops covered by stock dustboot, made sure the 3 holes were lined up)

From searching, I've found various suggestions as

-Swaybar needs regreasing (I've never had an issue with my front sway squeaking before, and wouldn't it also squeak as my car turns left and right?)
-tightening the 19mm topnut
-springs could be installed wrong

It doesn't seem to me to be a huge issue in regards to safety and performance, but I would like the sound to stop

Any suggestions?

Thanks for reading.
* Registered users of the site do not see these ads.
t_wrx is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-12-2012, 12:00 AM   #2
t_wrx
Scooby Newbie
 
Member#: 198217
Join Date: Dec 2008
Chapter/Region: SWIC
Location: Tempe
Vehicle:
2005 WRX
CGM never looks dirty!

Default

bump for ideas?
t_wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.