Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-08-2012, 03:22 PM   #1
KeithB01
Scooby Newbie
 
Member#: 334391
Join Date: Oct 2012
Default New boy from the UK

Hi folks. Actually I'm more of an old boy really-64 next January. I'm from a smallish town called Stourbridge in the region of the UK called the Midlands-largest city, Birmingham. I've got a 2008 Legacy 2.5 SEn which I've had for 2 years now. I think it's a great car but as I suspect was the case with US Legacies of a similar age, it doesn't have a great sound system, and that is the reason for my visiting your forum.

Whilst browsing to see what hints I might get on improving the sound I get in my car I came across an old thread on this forum which dated back to March 2008. It related to an announcement from Subaru at the 2008 New York Auto Show that for the 2009 models Harman Kardon amplifiers and speakers were going to be bolted to the existing head unit, which as far as I can make out from the photo in the thread, looks identical to the 1 I've got.

I'm not sure how far I should go with this post but it seems I can't start posting in the audio section without getting a few posts under my belt, so I've started here. I'm happy to elaborate on what I 'm trying to achieve, but would that be better done in the audio section in due course.

Anyway, for the time being, I'm glad I've found you and hope very much you'll be able to help. In return if there's anything I can help with as regards the UK I'll be happy to do so.

Keith
* Registered users of the site do not see these ads.
KeithB01 is offline   Reply With Quote
Old 10-08-2012, 04:39 PM   #2
Mishimoto
NASIOC Manufacturer
 
Member#: 207954
Join Date: Apr 2009
Default

Welcome to Nasioc!
Mishimoto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.