Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-06-2013, 10:04 PM   #1
swsubie
Scooby Newbie
 
Member#: 300133
Join Date: Nov 2011
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2008 WRX
SWP

Default Smoke, lots of it...

Alright, so heres the situation. I drive an 08 WRX and about 2 weeks ago I noticed it started to run hot for about all of 2 minutes, I immediately turned it off and popped the hood. When I looked under I noticed a decent amount of Oil just kind of gathering in the area of the skid plate closest to the oil cooler, and after looking closer noticed the Oil cooler itself was leaking... needless to say I pulled it apart last weekend and replaced the oil cooler and changed the oil/filter.

Everything was fine all week while driving. But, today (about 6 days later) on my way to work the car started smoking, A LOT. At one point the smoke even started coming into the cabin through the AC vent. I had no choice but to try and make it to work which was about a mile away and when I pulled into the parking garage and popped the hood it was hard to tell where the smoke was coming from. Also, i looked back and noticed there was a visible trail of me coming into the parking lot, which was Oil :/ the smoke looked white/grayish. I'm now at work and am just wondering where I should start looking for the issue at hand, I'm pretty new to working on my own car and if its something big i'll just have to take it to a mechanic. Any advice / input would be greatly appreciated.

edit: no cel's were showing when I pulled into the parking lot, and the car was not running hot according to the gauge.
* Registered users of the site do not see these ads.
swsubie is offline   Reply With Quote
Old 04-06-2013, 10:17 PM   #2
mitchkeller87
Scooby Newbie
 
Member#: 278819
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Minot, ND
Vehicle:
2008 WRX
Red

Default

I had a couple oil leaks in my 08. The first was coming from the oil dip stick not staying down. The second one was my oil filter was leaking from not being tightened down.
mitchkeller87 is offline   Reply With Quote
Old 04-06-2013, 10:38 PM   #3
swsubie
Scooby Newbie
 
Member#: 300133
Join Date: Nov 2011
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2008 WRX
SWP

Default

Quote:
Originally Posted by mitchkeller87 View Post
I had a couple oil leaks in my 08. The first was coming from the oil dip stick not staying down. The second one was my oil filter was leaking from not being tightened down.
Do you think the oil filter not bieng tightend down enough would have caused that amount of smoke?? I tightened it down as much as I could, but I did not use a filter wrench. I just bought this subie in Jan and this was the first oil change I had done to it, but in the past on other cars I have never used an filter wrench.
swsubie is offline   Reply With Quote
Old 04-06-2013, 10:45 PM   #4
Dakota D
Scooby Specialist
 
Member#: 293894
Join Date: Sep 2011
Chapter/Region: NWIC
Location: Billings,Mt
Vehicle:
2004 Subaru wrx
silver

Default

As long as you got a good arm hand tight should be fine. I would suggest looking at the oil cooler again since that's the last thing you touched.
Dakota D is offline   Reply With Quote
Old 04-07-2013, 12:14 AM   #5
Aaron'z 2.5RS
Scooby Guru
 
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
Vehicle:
'00 RS/WRX Stg5
'98 RS Stock

Default

Quote:
Originally Posted by Dakota D View Post
As long as you got a good arm hand tight should be fine. I would suggest looking at the oil cooler again since that's the last thing you touched.
This.. the oil cooler being where it is is a dead giveaway..

We cant put our heads in tyere and look, so its up to you.. should be pretty obvious once you start looking
Aaron'z 2.5RS is offline   Reply With Quote
Old 04-07-2013, 09:01 AM   #6
mitchkeller87
Scooby Newbie
 
Member#: 278819
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Minot, ND
Vehicle:
2008 WRX
Red

Default

I paid some idiots to change my oil when I was on vacation. By time I got home it had loosened itself up and drained almost all the oil out of the car. The car was smoking so bad I thought I blew the motor.
mitchkeller87 is offline   Reply With Quote
Old 04-07-2013, 06:47 PM   #7
swsubie
Scooby Newbie
 
Member#: 300133
Join Date: Nov 2011
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2008 WRX
SWP

Default

Quote:
Originally Posted by mitchkeller87 View Post
I paid some idiots to change my oil when I was on vacation. By time I got home it had loosened itself up and drained almost all the oil out of the car. The car was smoking so bad I thought I blew the motor.
That sounds like what happened to me. As soon as I get a day off I'm gonna get under there n check it out. I'm HOPING that's all it is.
swsubie is offline   Reply With Quote
Old 04-07-2013, 09:11 PM   #8
mitchkeller87
Scooby Newbie
 
Member#: 278819
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Minot, ND
Vehicle:
2008 WRX
Red

Default

I could smell the oil after a while. It was so bad the entire underside of my car was covered in oil.
mitchkeller87 is offline   Reply With Quote
Old 04-08-2013, 01:14 AM   #9
swsubie
Scooby Newbie
 
Member#: 300133
Join Date: Nov 2011
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2008 WRX
SWP

Default

I looked under my car after I got out of work this morning and there was oil EVERYWHERE... I'm hoping this is what happened, I'm thinking I left the gasket from the old oil filter on there and screwed the new filter and gasket in... So, unfortunately, in this case.. I'M the idiot lol. Hopefully this is all that it was though and itll be a quick, easy fix. Minus having to buy some more Royal Purple
Quote:
Originally Posted by mitchkeller87 View Post
I could smell the oil after a while. It was so bad the entire underside of my car was covered in oil.
swsubie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.