Welcome to the North American Subaru Impreza Owners Club Wednesday June 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-22-2012, 09:42 AM   #1
Zottyzot
Scooby Newbie
 
Member#: 62150
Join Date: May 2004
Location: Roslyn, PA
Vehicle:
2007 WRX wagon
UGM

Default Leaky Legacy

My girlfriend just bought a '99 outback SUS with a EJ2.5/AT.
It's very leaky...
The underside of the engine is coated in every kind of fluid there is. I replaced the power steering pump, because that was leaking. So, I'm gonna keep an eye, on that and see if things start to dry up at all.
There is also engine oil and some coolant on the underside.

I know that the headgaskets were replaced once. Are there any specific places I should be looking for the leaks? Perhaps this is a stupid question, but I'm just looking for a starting point....

Also, the temp gauge does not work (which makes me nervous with this engine) I check the wiring at the sensor, it's connected. Are the sensors known to go bad? Should I just put in a new one and cross my fingers?

Thanks in advance...
* Registered users of the site do not see these ads.
Zottyzot is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.