Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-26-2012, 09:10 AM   #1
tanz1983
Scooby Newbie
 
Member#: 131047
Join Date: Nov 2006
Location: Milton, Fl
Default cam slipage

I recently changed my timing belt with great results. the car ran fine for a while. Now, with the weather change, while driving, the engine will squeak for a second and and go back to normal. I don't feel too much. I cant tell if its the road or a minute loss of power. I am getting a P006, P007, P009 code. i can't even find this code. Any have any ideas?

2006 wrx tr with mostly suspension mods and some minor engine upgrades. Just a new turbo and full exhaust and tuning.
* Registered users of the site do not see these ads.
tanz1983 is offline   Reply With Quote
Old 10-26-2012, 12:50 PM   #2
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

A quick check tells me there should be 4 digits in any code, not 3. That could be the raisin you can't find the code.
some dude is offline   Reply With Quote
Old 10-26-2012, 01:15 PM   #3
stevejones19
Scooby Specialist
 
Member#: 275250
Join Date: Feb 2011
Chapter/Region: NWIC
Location: Lacey, WA
Vehicle:
2006 WRX
White

Default

Minute loss of power? How do you know? Do you have any control to check it against? could be that you are just getting used to it and it doesn't have the same effect anymore. And the squeak could be your power steering belt. Have you used any engine bay cleaners at all? I've personally found that those are prone to making your belt go out sooner.
stevejones19 is offline   Reply With Quote
Old 10-29-2012, 11:40 AM   #4
tanz1983
Scooby Newbie
 
Member#: 131047
Join Date: Nov 2006
Location: Milton, Fl
Default

no belt cleaners. brand new belts all around. the first digit is a 2 which is for electrical issues. I thought it was power steering until I could feel a momentary loss of power. while in 5th gear at a steady speed, the car will squeak and lose power and regain it very quickly.
tanz1983 is offline   Reply With Quote
Old 10-29-2012, 12:11 PM   #5
holyjoetart
Scooby Newbie
 
Member#: 232986
Join Date: Dec 2009
Location: Rock Springs, WY
Vehicle:
07 Legacy GT
OBP

Default

Sounds like it could be your a/c clutch engaging, causing the power problem. It happens on my buddy's '03. Unplug your compressor clutch and take it on a drive and see if it helps.
holyjoetart is offline   Reply With Quote
Old 10-29-2012, 04:27 PM   #6
Paidfor
Scooby Specialist
 
Member#: 267815
Join Date: Dec 2010
Chapter/Region: South East
Location: 04STi JAVA
Vehicle:
EVO Woudve been
Cheaper!!!!!

Default

^^^^If the ac comp kickin in causes a noticable loss of power...........its time for a V8
Paidfor is offline   Reply With Quote
Old 10-30-2012, 10:10 AM   #7
tanz1983
Scooby Newbie
 
Member#: 131047
Join Date: Nov 2006
Location: Milton, Fl
Default

For some reason the problem fixed itself. Thanks for the input guys. I wish I could afford the V8 conversion
tanz1983 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:21 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.