Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-01-2013, 10:40 PM   #76
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

Got my safety papers and applied for my insurance.. insurance is going to take 7-10 buisness days before they put my quote together or somthing? ... -.- THEN its smooth sailing from there! also its hilarious to hear my dad and his friends debate whether my exhaust is actually stainless... "back in my day a real stainless exhaust would cost a fortune" "stainless exhaust are never used for automobiles" i guess the times have changed in my favour



* Registered users of the site do not see these ads.

Last edited by Qwikyking; 04-02-2013 at 11:36 AM.
Qwikyking is offline   Reply With Quote
Old 04-04-2013, 07:01 PM   #77
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

POW! i chanced it and bought the rims, they look FAN TASTIC





clearance

rear


front
Qwikyking is offline   Reply With Quote
Old 04-08-2013, 08:33 PM   #78
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

started the next project, can anyone guess?



Qwikyking is offline   Reply With Quote
Old 04-08-2013, 10:51 PM   #79
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

as far as i could get tonight, any guesses?

Qwikyking is offline   Reply With Quote
Old 04-08-2013, 10:54 PM   #80
Longinus
Scooby Specialist
 
Member#: 187727
Join Date: Aug 2008
Chapter/Region: SCIC
Location: Los Angeles
Vehicle:
2001 GC6 Impreza
BRP with a dash of mud

Default

Will you be making a mold for a lip?
Longinus is offline   Reply With Quote
Old 04-08-2013, 10:58 PM   #81
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

a hatch spoiler, its gonna look alot like the gc8 wagon spoiler. i know i can just buy one... but this is way more fun plus the grand total for this project so far.....

$15 - 2'x8' foam
Qwikyking is offline   Reply With Quote
Old 04-08-2013, 11:18 PM   #82
that_nicker
Scooby Newbie
 
Member#: 343208
Join Date: Jan 2013
Chapter/Region: Tri-State
Vehicle:
1993 Impreza L
Green/Blue

Default

What did you do to fix the rust holes? My L has massive rust holes on both sides. Looks good though. This is a tough car to find performance bits for though.
that_nicker is offline   Reply With Quote
Old 04-08-2013, 11:33 PM   #83
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

Quote:
Originally Posted by that_nicker View Post
What did you do to fix the rust holes? My L has massive rust holes on both sides. Looks good though. This is a tough car to find performance bits for though.
to pass safety i used a few layers of aluminum tape once the weather clears up and i get my insurance i plan on welding in new patches
the L is so similar to all the other models from 96-2001(?) the exhaust i got is for a 2.5 rs the rims i got are from a 2007 impreza. i think youd be surprised what will fit your L
Qwikyking is offline   Reply With Quote
Old 04-09-2013, 12:00 PM   #84
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

got a little more done today, theres gonna be alot of sanding ahead



Qwikyking is offline   Reply With Quote
Old 04-09-2013, 01:22 PM   #85
lub
Scooby Newbie
 
Member#: 343218
Join Date: Jan 2013
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2004 WRX wagon
Blue

Default

This is an awesome pickup for $450!
lub is offline   Reply With Quote
Old 04-13-2013, 01:32 AM   #86
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

almost done .\m/

just need to shape it, and make sure it will fit against the window snugly then i can get the bondo rolling


Qwikyking is offline   Reply With Quote
Old 04-13-2013, 01:50 AM   #87
Longitude
Scooby Guru
 
Member#: 2216
Join Date: Aug 2000
Location: Stay Classy __
Vehicle:
0000 Gee See
dented

Default

Very interesting, looking forward to more progress
Longitude is offline   Reply With Quote
Old 04-20-2013, 04:29 PM   #88
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

Its finally on the road, took long enough


Qwikyking is offline   Reply With Quote
Old 04-23-2013, 12:44 AM   #89
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

well, its finally being used,
now i've got some kinks to iron out
Gas milage;
filled up to 3/4, now at 1/4 after 80kms so thats roughly.... 7.5 mpg.... HA wow that sucks....
i think it could be
-Temp sensor * cheapest
-hole in fuel line somewhere?
-gummed up plugs/injectors

Tick,Tick,Tick,Tick from just above idle, to low/mid cruising rpms (no tach )
could be...
-HLA (hydrolic lash adjusters)
-Timing slightly off
-Timing belt tensioner (pretty sure its this one)

oh and some other random noises
-leaves in my vents/blower
-squeaky chair..
-clutch whine...



not too worried about the engine, i'll be looking around at scrapyards for a nice ej22, with tranny and manifold/Cat still on it, bolt right up to my current exhaust, work on the body this summer. should be eventfull
Qwikyking is offline   Reply With Quote
Old 04-23-2013, 01:04 AM   #90
cmk82600
Scooby Newbie
 
Member#: 248305
Join Date: Jun 2010
Location: Minnesota
Vehicle:
97 OBS
my custom mixed silver

Default

All Subarus tick.
cmk82600 is offline   Reply With Quote
Old 04-23-2013, 01:06 AM   #91
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

Quote:
Originally Posted by cmk82600 View Post
All Subarus tick.
i'll try and get a video of it, maybe i'm just used to quiet little inline4's
Qwikyking is offline   Reply With Quote
Old 04-24-2013, 09:20 PM   #92
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

changing spark plugs....
old .79
new.43


and changing timing belt soon too.. fun

Qwikyking is offline   Reply With Quote
Old 04-24-2013, 11:34 PM   #93
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

well i got them all changed, put a film of antiseize and plugged them all back in... start it up... RUNNING LIKE $Hi%.... smell of unburnt gas.....AHHH HA, gotta be an unplugged wire... push all plug wires as hard as possible.. still runs like crap... push them till my fingers bleed...runs great
SO.. lesson learnt.. plug wires are ON TIGHT.



the car drives almost exactly the same no real difference in power or feel.

i think my fuel leak is somewhere on the gas line,
it cant be temp sensor-plugs all have nice gold colour (right fuel mix), i can read temp with my obd
i dont think knock sensor would affect it that much.... but im going to check it for cracks etc (would rather not replace it... its $80)
Qwikyking is offline   Reply With Quote
Old 04-24-2013, 11:37 PM   #94
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

also the spoiler is coming along

Qwikyking is offline   Reply With Quote
Old 04-24-2013, 11:57 PM   #95
street carp
Scooby Specialist
 
Member#: 216768
Join Date: Jul 2009
Chapter/Region: NWIC
Location: tacoma
Vehicle:
2004 STI

Default

this car is so bad ass for $450...

my parents have a 96 sedan with a 2.2L 5 speed. i think when i move back home i'll fix that up as my daily beater car. it looks just like this car, just sedan!
street carp is offline   Reply With Quote
Old 04-26-2013, 06:32 PM   #96
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

so it seems that the new plugs are helping my gas milage a little more? or showing more problems

either my eyes were deceiving me or my fuel gauge is trying to be a comedian.
-leave home with 1/2 tank, get to school with gauge gone down small amount
-leave school with 1/2 tank get to girlfriends with gauge gone down slightly
-leave girlfirend with slightly less than 1/2 get home and its down to 1/4
atleast my car gets good daytime milage?
might have to open the fuel tank inspection hatches and check some voltages etc.

horn stopped working after large snowfall and blew a fuse, so i gotta find where the electrical short is. probably means a new horn.

going to get a new timing belt soon,

need to checkout transmission stuff, 1st & R were grinding more than usual today (first hot day this spring)

double check front wheel alignment

and then i found this little gem.

(right side of steering colomn above gas pedal )


WHAT THE F^%$ !?!?1 anyone have any idea what this might be? i'll leave it unplugged for now, not sure what its for.


EDIT: just searched and its for diagnostics? i've also read that they should be plugged in.... i can never trust the internet.

Last edited by Qwikyking; 04-26-2013 at 06:42 PM.
Qwikyking is offline   Reply With Quote
Old 04-26-2013, 07:13 PM   #97
cmk82600
Scooby Newbie
 
Member#: 248305
Join Date: Jun 2010
Location: Minnesota
Vehicle:
97 OBS
my custom mixed silver

Default

They get plugged in when doing diagnostics.
cmk82600 is offline   Reply With Quote
Old 04-26-2013, 07:17 PM   #98
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

Quote:
Originally Posted by cmk82600 View Post
They get plugged in when doing diagnostics.
thankyou for clarification
Qwikyking is offline   Reply With Quote
Old 04-29-2013, 08:38 PM   #99
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

02 sensors could be a cluprit of part of the bad mileage. cleaned MAF is a easy place to start.
auskip07 is offline   Reply With Quote
Old 04-29-2013, 09:34 PM   #100
Qwikyking
Scooby Newbie
 
Member#: 336666
Join Date: Oct 2012
Location: CANADA
Vehicle:
1997 impreza wagon
teal/barf

Default

Ive cleaned the whole intake past the throttle body also i do not have the rear o2 sensor because im too cheap for replacing the cat
Qwikyking is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.