Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-24-2013, 11:35 PM   #51
USAFAndrei
Scooby Newbie
 
Member#: 352158
Join Date: Apr 2013
Chapter/Region: NESIC
Location: NH
Vehicle:
2012 Impreza
Metallic Grey

Default

Finished the new project. LED's spliced with left parking light.
* Registered users of the site do not see these ads.
USAFAndrei is online now   Reply With Quote
Old 11-24-2013, 11:39 PM   #52
kinger37
Scooby Newbie
 
Member#: 324423
Join Date: Jun 2012
Location: CT
Vehicle:
2012 Impreza Sport
ISM

Default

You need to put white led's in your corner eyebrow lights now
kinger37 is offline   Reply With Quote
Old 11-25-2013, 01:16 AM   #53
USAFAndrei
Scooby Newbie
 
Member#: 352158
Join Date: Apr 2013
Chapter/Region: NESIC
Location: NH
Vehicle:
2012 Impreza
Metallic Grey

Default

Yea im thinking that too. Sucks getting the grille off tho so annoying I've done it like 5 times now.
USAFAndrei is online now   Reply With Quote
Old 11-25-2013, 02:22 AM   #54
USAFAndrei
Scooby Newbie
 
Member#: 352158
Join Date: Apr 2013
Chapter/Region: NESIC
Location: NH
Vehicle:
2012 Impreza
Metallic Grey

Default

USAFAndrei is online now   Reply With Quote
Old 11-25-2013, 06:38 AM   #55
TRSAndrew
Scooby Newbie
 
Member#: 360634
Join Date: Jun 2013
Location: ATL
Vehicle:
2013 XV Crosstrek
Orange

Default

Quote:
Originally Posted by USAFAndrei View Post
Yea im thinking that too. Sucks getting the grille off tho so annoying I've done it like 5 times now.
That's why you just drop the bumper instead. Super easy.
TRSAndrew is offline   Reply With Quote
Old 11-25-2013, 08:03 AM   #56
goregasm
*** Banned ***
 
Member#: 331656
Join Date: Sep 2012
Vehicle:
2012 2.0i
Marine Blue Pearl

Default

Quote:
Originally Posted by TRSAndrew View Post
That's why you just drop the bumper instead. Super easy.
How do?
goregasm is offline   Reply With Quote
Old 04-26-2014, 10:20 AM   #57
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Bump for an old thread.

Just finished installing my Super tones after an accident where the guys car rolled backward into mine (yes there was plenty of space but never enough when they dont hear your horn and are oblivious for the 5-6 seconds the car is rolling back on a hill)

I did install them like the OP they are VERY loud.
auskip07 is online now   Reply With Quote
Old 04-26-2014, 10:51 AM   #58
CalTech87
Scooby Specialist
 
Member#: 348055
Join Date: Feb 2013
Location: San Diego
Vehicle:
2013 Impreza 5MT
ISM

Default

Quote:
Originally Posted by auskip07 View Post
Bump for an old thread.

Just finished installing my Super tones after an accident where the guys car rolled backward into mine (yes there was plenty of space but never enough when they dont hear your horn and are oblivious for the 5-6 seconds the car is rolling back on a hill)

I did install them like the OP they are VERY loud.
Glad to hear it worked out. Ive had the supertones for a number of months now and hardly ever use them even though Im in SD and actually should be using them on a daily basis.

Sometimes with loud horns I think they may actually be dangerous scaring people into hitting their brakes or the number of motocycles that are lane splitting...
CalTech87 is offline   Reply With Quote
Old 04-27-2014, 09:53 AM   #59
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Quote:
Originally Posted by CalTech87 View Post
Glad to hear it worked out. Ive had the supertones for a number of months now and hardly ever use them even though Im in SD and actually should be using them on a daily basis.

Sometimes with loud horns I think they may actually be dangerous scaring people into hitting their brakes or the number of motocycles that are lane splitting...
in my case scaring someone into hitting their brakes would have been a good thing. They are certainly scary loud. My wife had to cover he ears when she heard them.
auskip07 is online now   Reply With Quote
Old 08-04-2014, 09:03 AM   #60
Dill-Ag13
Scooby Newbie
 
Member#: 316535
Join Date: Apr 2012
Chapter/Region: TXIC
Location: The Woodlands, TX
Vehicle:
2012 Impreza Sp Prem
Grey

Default

Three questions:
1. Can someone advise me on how to remove the OEM horn wire socket/plug? I've yanked the heck out of it but it won't budge.
2. Can I ground both the horns and the relay to the same M6-1.0 mounting position suggested in the OP?
3. All wires are single strand, correct?
Dill-Ag13 is offline   Reply With Quote
Old 08-04-2014, 12:22 PM   #61
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Quote:
Originally Posted by Dill-Ag13 View Post
Three questions:
1. Can someone advise me on how to remove the OEM horn wire socket/plug? I've yanked the heck out of it but it won't budge.
2. Can I ground both the horns and the relay to the same M6-1.0 mounting position suggested in the OP?
3. All wires are single strand, correct?
1. press down on the tab and pull.
2. why would you run all that grounding wire. Ground it to the nearest point. Grounds are dumb and not picky
3. No idea what you mean
auskip07 is online now   Reply With Quote
Old 08-04-2014, 01:13 PM   #62
Dill-Ag13
Scooby Newbie
 
Member#: 316535
Join Date: Apr 2012
Chapter/Region: TXIC
Location: The Woodlands, TX
Vehicle:
2012 Impreza Sp Prem
Grey

Default

Quote:
Originally Posted by auskip07 View Post
1. press down on the tab and pull.
2. why would you run all that grounding wire. Ground it to the nearest point. Grounds are dumb and not picky
3. No idea what you mean


1. What tab? I am unable to find a tab to press down on.
2. I have it lying around and I'd like to neatly ground it to the same point since I have wires running that direction anyways.
Dill-Ag13 is offline   Reply With Quote
Old 08-04-2014, 02:07 PM   #63
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Quote:
Originally Posted by Dill-Ag13 View Post
1. What tab? I am unable to find a tab to press down on.
2. I have it lying around and I'd like to neatly ground it to the same point since I have wires running that direction anyways.
The tab to the horn that is on the middle bottom of where you are mounting the new horns. Feel around for it. Find the ridged part and squeeze and pull. That is where i ran my signal wire for the relay.
auskip07 is online now   Reply With Quote
Old 08-04-2014, 02:55 PM   #64
Dill-Ag13
Scooby Newbie
 
Member#: 316535
Join Date: Apr 2012
Chapter/Region: TXIC
Location: The Woodlands, TX
Vehicle:
2012 Impreza Sp Prem
Grey

Default

Quote:
Originally Posted by auskip07 View Post
The tab to the horn that is on the middle bottom of where you are mounting the new horns. Feel around for it. Find the ridged part and squeeze and pull. That is where i ran my signal wire for the relay.
Ok, I'll give it a look, thanks
Dill-Ag13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.