Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-20-2012, 03:58 PM   #51
SlverEJ20
Scooby Specialist
 
Member#: 157158
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Fairfax, Va
Vehicle:
05 WRX stage 2
PSM

Default

You could start swapping the coil packs around to see if the miss fire follows a coil pack. Or ask one if your local forum members if you could borrow there coil packs to see if that fixes the issue
* Registered users of the site do not see these ads.
SlverEJ20 is offline   Reply With Quote
Old 11-20-2012, 04:08 PM   #52
tersplat
Scooby Specialist
 
Member#: 337888
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Groton, CT
Vehicle:
2003 WRX Wagon
World Rally Blue

Default

I am not throwing any codes. How do I know which one is misfiring?
tersplat is offline   Reply With Quote
Old 11-21-2012, 10:45 AM   #53
oOIIJoshIIOo
Scooby Newbie
 
Member#: 295983
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Clendenin, WV
Vehicle:
2002 WRX
WRB

Default

Quote:
Originally Posted by tersplat
I am not throwing any codes. How do I know which one is misfiring?
You won't. Just buy a new one and switch it around until problem solved. Unless there is more than one coil bad, but it isn't likely at the same time. Most of the time a bad coil doesn't throw any code at all.
oOIIJoshIIOo is offline   Reply With Quote
Old 11-21-2012, 12:46 PM   #54
simpsonsdotcom
Scooby Newbie
 
Member#: 269543
Join Date: Jan 2011
Location: Richmond, VA
Vehicle:
2002 2.5RS BRP
2004 WRX WRB

Default

Yeah that's what I ended up doing. I think it will only throw a code once it is really bad or misfiring. Mine sure felt like it was misfiring but never threw a code for one.
simpsonsdotcom is online now   Reply With Quote
Old 11-21-2012, 04:17 PM   #55
tersplat
Scooby Specialist
 
Member#: 337888
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Groton, CT
Vehicle:
2003 WRX Wagon
World Rally Blue

Default

Alright, Thanks. Are there any known issues with the duralast coils from Autozone? Or should I buy genuine Subaru?
tersplat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.