Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-01-2012, 08:58 PM   #26
Wumpus02
Scooby Newbie
 
Member#: 250233
Join Date: Jun 2010
Chapter/Region: MAIC
Location: Elkton, MD
Vehicle:
2002 WRX Wagon
World Rally Blue

Default

UPDATE!!!! Turns out neither the throw out bearing nor the clutch fork were damage. However, this is what we found when we separated the transmission from the engine.



Broken clip.

Going to call JSC Speed and see what they can do about this.
* Registered users of the site do not see these ads.
Wumpus02 is offline   Reply With Quote
Old 12-02-2012, 11:56 PM   #27
Tut4u2
Scooby Specialist
 
Member#: 40424
Join Date: Jul 2003
Chapter/Region: MAIC
Location: PA
Vehicle:
Its a boat
on jack stands

Default

Which clip is broken? Are you talking about the c clip?
Tut4u2 is offline   Reply With Quote
Old 12-03-2012, 12:50 AM   #28
ThunderousProduction
Scooby Newbie
 
Member#: 282899
Join Date: May 2011
Default

Hey just saw this thread and if you need any additional help id be glad to help ya, im located in Elkton, MD as well so it cant be a far drive. Ive completely disassembled changed all the gears and reassembled my 2006 wrx tranny so I know a few tricks haha
ThunderousProduction is offline   Reply With Quote
Old 12-03-2012, 08:37 AM   #29
Wumpus02
Scooby Newbie
 
Member#: 250233
Join Date: Jun 2010
Chapter/Region: MAIC
Location: Elkton, MD
Vehicle:
2002 WRX Wagon
World Rally Blue

Default

There are two clips that appear to have failed.
Wumpus02 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:01 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.