Welcome to the North American Subaru Impreza Owners Club Sunday April 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-24-2013, 02:45 PM   #1
JoeyS07sti
Scooby Newbie
 
Member#: 218475
Join Date: Jul 2009
Chapter/Region: TXIC
Location: PEARLAND/HOUSTON
Vehicle:
2007 CGM STI

Default Need help diagnosing my STI

Hi my name is Joey, I have a 2007 STI with only 45k on it. I have some sort of problem up front, it is a wobbling sensation at low speeds, accompanied with a noise that sounds kinda like when you turn to sharp with AWD. It also pulls hard to the right when I punch it. So far we have the transmission out and front differential seperated, and still do not see any visual problems.
Some history on the car, I bought in 07 got in a wreck due to someone else's negligence (some a**hat running from the cops), the accident did not affect the chassis majorly or any of my suspension I believe. One note is that the people I take it to get the alignment done told me I needed to get aftermarket camber bolts in order to properly align it anymore. We also installed an EXEDY three puck racing HD clutch (ourself, my dad has been a mechanic for over 30+years) which had too much chatter for me(so I sold it the other day), and I am not sure if the noise occurred before or after the clutch install due to it not being my primary vehicle anymore, and it has been a long time.
We can not figure out what it is at this point.

If you can think of any ideas that would help me thanks!
Reply here, PM me, or email me at j.saa.engratgmail.com
* Registered users of the site do not see these ads.
JoeyS07sti is offline   Reply With Quote
Old 04-24-2013, 06:02 PM   #2
Antiharper
Scooby Newbie
 
Member#: 350489
Join Date: Mar 2013
Location: Ontario canada
Vehicle:
09 Impreza 2.5i

Default

Dude it sounds like basic suspension problem , torque steer. Maybe shifted belt in tires? Why the hell would u take the transmission out? Axle damage? This shouldn't be a hard diagnosis. Take it to a good mechanic pay the $20 he's gunna charge you.
Antiharper is offline   Reply With Quote
Old 04-24-2013, 06:06 PM   #3
JoeyS07sti
Scooby Newbie
 
Member#: 218475
Join Date: Jul 2009
Chapter/Region: TXIC
Location: PEARLAND/HOUSTON
Vehicle:
2007 CGM STI

Default

Forgot to mention when we switch the dccd to rear, if all is normal. That is why plus I wanted to change the clutch.
JoeyS07sti is offline   Reply With Quote
Old 04-24-2013, 09:43 PM   #4
JoeyS07sti
Scooby Newbie
 
Member#: 218475
Join Date: Jul 2009
Chapter/Region: TXIC
Location: PEARLAND/HOUSTON
Vehicle:
2007 CGM STI

Default

Quote:
Originally Posted by JoeyS07sti View Post
Forgot to mention when we switch the dccd to rear, if all is normal. That is why plus I wanted to change the clutch.
* it is all normal
JoeyS07sti is offline   Reply With Quote
Old 04-27-2013, 09:31 PM   #5
Antiharper
Scooby Newbie
 
Member#: 350489
Join Date: Mar 2013
Location: Ontario canada
Vehicle:
09 Impreza 2.5i

Default

Quote:
Originally Posted by JoeyS07sti View Post

* it is all normal
Ok. So you've narrowed it down to a gearing issue. When you had the diff apart did you replace bearings? Gears binding?
Antiharper is offline   Reply With Quote
Old 04-27-2013, 09:46 PM   #6
JoeyS07sti
Scooby Newbie
 
Member#: 218475
Join Date: Jul 2009
Chapter/Region: TXIC
Location: PEARLAND/HOUSTON
Vehicle:
2007 CGM STI

Default

Quote:
Originally Posted by Antiharper View Post

Ok. So you've narrowed it down to a gearing issue. When you had the diff apart did you replace bearings? Gears binding?
I have not replaced any bearings yet. Which ones should I look at? Gear binding is what it sounds like as far as the sound it makes when the dccd is in auto mode.
JoeyS07sti is offline   Reply With Quote
Old 04-28-2013, 05:59 AM   #7
J_gun
*** Banned ***
 
Member#: 354810
Join Date: Apr 2013
Default

don't know aye.
J_gun is offline   Reply With Quote
Old 04-28-2013, 10:13 AM   #8
JoeyS07sti
Scooby Newbie
 
Member#: 218475
Join Date: Jul 2009
Chapter/Region: TXIC
Location: PEARLAND/HOUSTON
Vehicle:
2007 CGM STI

Default

Quote:
Originally Posted by J_gun View Post
don't know aye.
Thanks for the free bump.
JoeyS07sti is offline   Reply With Quote
Old 05-30-2013, 02:41 PM   #9
JoeyS07sti
Scooby Newbie
 
Member#: 218475
Join Date: Jul 2009
Chapter/Region: TXIC
Location: PEARLAND/HOUSTON
Vehicle:
2007 CGM STI

Default

For anyone who cared, or has the same problem, it was the passenger side front differential roller bearing. Some how it warped, and it looks like it is due to someone bottoming out pretty bad. Car is fixed now, and drives perfectly again. Hope this helps!
JoeyS07sti is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.