Welcome to the North American Subaru Impreza Owners Club Sunday October 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-13-2012, 04:17 PM   #1
Mangledmess1
Scooby Newbie
 
Member#: 286858
Join Date: Jun 2011
Location: Orange County
Vehicle:
2002 Impreza WRX
Blue

Default Problem in reverse??? (Noob)

I just had my transmission changed after i broke my original one. Wall backing up it feels like there is break pressure being applied or binding.
* Registered users of the site do not see these ads.
Mangledmess1 is offline   Reply With Quote
Old 11-13-2012, 04:55 PM   #2
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

Did you change it or have a shop do it? If a shop did it then take it back to them and go from there.
some dude is offline   Reply With Quote
Old 11-16-2012, 10:25 AM   #3
Mangledmess1
Scooby Newbie
 
Member#: 286858
Join Date: Jun 2011
Location: Orange County
Vehicle:
2002 Impreza WRX
Blue

Default

Quote:
Originally Posted by some dude
Did you change it or have a shop do it? If a shop did it then take it back to them and go from there.
I had a shop do it but I supplied the trans. And the sticky breaks feeling was because i got a light weight fly wheel. Have to rev it higher to move the car now like 2k.
Mangledmess1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.