Welcome to the North American Subaru Impreza Owners Club Thursday August 25, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-13-2012, 09:10 PM   #1
RallyBot 6.0
Scooby Newbie
 
Member#: 337195
Join Date: Nov 2012
Chapter/Region: NWIC
Location: MT. HOOD Vancouver, WA
Vehicle:
2002 WRX
Maroon/black

Default klickidy klank and high idle - i am a turbo noob.

like the title says, im a turbo noob. just got the whip, 02'wrx, ran into issues getting my oil change, and now noticing a couple other. first off, my idle is at like 1300 after its warmed up. also, ill rev the throttle cable.. vrrrrrrmmmmmm.. let off.. clak clak clah. sounds near the bottom of block.. pass side maybe. i know its got an exhaust leak right after the cat (farthest back one) looks like it was high centered. besides that it doesnt seem to have any other problems. i was told that if the knocking sound is coming from the block after your rev it, it could be a bearing?

edit - i have noticed a couple other knocks/ticks but they were temporary. also, i cut two coolant lines shorter that go from radiator and coolant resivor to the other resivor that sits on top of the motor. also re-routed them so they go down along side of motor and then strait up to top resivor. (to make room for custom air box) i figured it would be fine because there pressurized, but having second thoughts on kind of ristricting flow. here's a pic of the the two hoses im talking about (left two in blue color) not my car.

* Registered users of the site do not see these ads.

Last edited by RallyBot 6.0; 11-13-2012 at 11:13 PM.
RallyBot 6.0 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-13-2012, 11:11 PM   #2
RallyBot 6.0
Scooby Newbie
 
Member#: 337195
Join Date: Nov 2012
Chapter/Region: NWIC
Location: MT. HOOD Vancouver, WA
Vehicle:
2002 WRX
Maroon/black

Default

i was told these motors are suppose to idle at 800rpm's. my buddy also said he thinks it might be a 2.5 block so maybe thats why. but i really have no idea. i got a good deal on the rig and have only built vr6 jetta's and gti's. never played with a turbo motor. also id like to know if shortening and rerouting the coolant hoses would cause me any trouble. thanks.
RallyBot 6.0 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.