Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Canada Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Canada Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-11-2002, 03:12 PM   #1
Robin2
NASIOC Supporter
 
Member#: 390
Join Date: Oct 1999
Chapter/Region: E. Canada
Location: Ottawa, Ontario, Canada
Vehicle:
2011 WRX sedan
Plasma Blue

Default Attn: 1999 Subarus with MAF sensors

FYI..... I saw this posted on the Toronto Club.

Two of their members have already confirmed that they will have their MAF sensor on 1999 Subaru Imprezas replaced at no charge....

I called my local dealer and he confirmed to me about my own 1999 Impreza RS and if I should have it brought in.

If you're subaru has a MAF sensor (mainly 1999's), contact your dealer..... They'll need your VIN # to verify with Subaru Canada.

Robin
NCSC
* Registered users of the site do not see these ads.
Robin2 is offline   Reply With Quote
Old 09-11-2002, 08:41 PM   #2
RallyOttawa
Scooby Newbie
 
Member#: 14303
Join Date: Jan 2002
Location: Seattle, WA
Vehicle:
1999 Impreza RS 2.5
Black

Default

Excellent...
RallyOttawa is offline   Reply With Quote
Old 09-12-2002, 08:38 AM   #3
direwlf
Scooby Specialist
 
Member#: 1479
Join Date: May 2000
Chapter/Region: W. Canada
Location: Calgary, Alberta, Canada
Vehicle:
1999 Impreza 2.5RS
Silverthorn Metallic

Default

I had mine done a few months ago when I was in the dealership for my 48k checkup. The service advisor told me there would be a TSB coming in a week so they just replaced it anyways, since the car was already there.
direwlf is offline   Reply With Quote
Old 09-12-2002, 11:17 AM   #4
Swatch
Scooby Newbie
 
Member#: 24431
Join Date: Sep 2002
Chapter/Region: E. Canada
Location: Chambly, Québec
Vehicle:
2002 Impreza WRX
silver

Default

Allready replace Two time !

First time was for the recall, and I blow the second one with my Ractive air filter (to much oil )

The second one was replace without any questions !
Swatch is offline   Reply With Quote
Old 09-12-2002, 11:53 AM   #5
HOK
Scooby Specialist
 
Member#: 447
Join Date: Oct 1999
Location: Oh Canada
Vehicle:
1999 EJ22T222B&EVO
Are we racing yet?

Default

warren... was this at SOC?? if so can you ask paul when this will be availble until, if you happen to go in or something? i'm still out of town...
HOK is offline   Reply With Quote
Old 09-12-2002, 07:24 PM   #6
direwlf
Scooby Specialist
 
Member#: 1479
Join Date: May 2000
Chapter/Region: W. Canada
Location: Calgary, Alberta, Canada
Vehicle:
1999 Impreza 2.5RS
Silverthorn Metallic

Default

Quote:
Originally posted by HOK
warren... was this at SOC?? if so can you ask paul when this will be availble until, if you happen to go in or something? i'm still out of town...
My car is due in for a service, I'll ask him when I get the car in. I don't think there's a time limit on it.
direwlf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Houston, need help with MAF sensor Wheeler Bement Texas Impreza Club Forum -- TXIC 5 01-23-2008 01:14 AM
Need help with MAF sensor skydes Service & Maintenance 3 05-11-2007 01:57 PM
WTB: 1999 Subaru Impreza MAF sensor OriginalFive VIC Private Classifieds 0 03-18-2007 09:13 PM
WTB: 1999 Subaru Impreza MAF sensor OriginalFive Private 'Wanted' Classifieds 0 03-18-2007 09:10 PM
1999 Subaru Impreza MAF sensor problem? OriginalFive Normally Aspirated Powertrain 1 03-04-2007 06:49 PM


All times are GMT -4. The time now is 08:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.