Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-16-2012, 01:10 AM   #1
OC_Nooby
Scooby Specialist
 
Member#: 311781
Join Date: Feb 2012
Location: Canada
Vehicle:
2003 WRX w STI V8

Default What is your EGT reading at 120kms/75mph

Hey all,

Just wanted to know what EGT readings people are getting from there 2.5l stock or very close to stock STI motors while cruising at 120kms/75mph.

Specify the following:

EGT:
Air to Fuel ratio:
Stock EGT sensor or aftermarket:
O2 sensor or Wideband:
EGT sensor location:

I want to get an idea of what other see in temps.

Thanks!
* Registered users of the site do not see these ads.
OC_Nooby is offline   Reply With Quote
Old 11-16-2012, 01:12 AM   #2
OC_Nooby
Scooby Specialist
 
Member#: 311781
Join Date: Feb 2012
Location: Canada
Vehicle:
2003 WRX w STI V8

Default

EGT: 600C
Air to Fuel ratio: 14.4
Stock EGT sensor or aftermarket: Aftermarket
O2 sensor or Wideband: Wideband
EGT sensor location: Stock
OC_Nooby is offline   Reply With Quote
Old 11-16-2012, 11:47 AM   #3
tazswing
Scooby Specialist
 
Member#: 63767
Join Date: Jun 2004
Chapter/Region: NWIC
Location: PDX
Vehicle:
2009 OXT 5-spd
2011 STi hatch

Default

When you say "cruising" I am assuming you are taking about very little load?
tazswing is offline   Reply With Quote
Old 11-16-2012, 05:30 PM   #4
OC_Nooby
Scooby Specialist
 
Member#: 311781
Join Date: Feb 2012
Location: Canada
Vehicle:
2003 WRX w STI V8

Default

Quote:
Originally Posted by tazswing View Post
When you say "cruising" I am assuming you are taking about very little load?
Yes 0.75-0.8 Load
OC_Nooby is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.