Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-26-2013, 05:15 PM   #426
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

Hey everyone, stay tuned to this thread for a custom Nexus 7 boot screen I'll be posting up tonight around 11pm. It'll be for STi only, but I can possibly make more if there's demand. Video to follow in an hour or two. I have no plans on changing the Google splash screen due to the complexity.

Demonstration Video

Thanks to GOFASTSTI over on IWSTI for the base image!
* Registered users of the site do not see these ads.

Last edited by voltic; 03-26-2013 at 08:40 PM.
voltic is offline   Reply With Quote
Old 03-26-2013, 05:58 PM   #427
P.J.
Scooby Newbie
 
Member#: 116369
Join Date: May 2006
Chapter/Region: BAIC
Vehicle:
2012 STi sedan
silver, Stage 2

Default

you all are talking about menu screens for a Nexus 7 as headunit

I use "Car Home Ultra" as seen below.

Link and detail to my convertible tablet install: http://forums.nasioc.com/forums/show...3#post38633243
P.J. is offline   Reply With Quote
Old 03-26-2013, 08:02 PM   #428
mechatricity
Scooby Specialist
 
Member#: 290592
Join Date: Aug 2011
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
04 WRX Wagon,
15 WRX 6MT CWP

Default

Really great work to all of you on the N7 integration. lots of great information in this thread.

I'm slowly finalizing my designs for a complete gauge cluster replacement using Torque and a Nexus 7. This will be in my 06 WRX, so there's nothing particularly interesting or mission critical in the cluster that Torque can't replicate. Currently the plan is to not use it for anything other than displaying gauge information. My Note 2 handles BT media streaming, calls, and navigation.

I think i have a path forward on controlling power and charging in a semi-permanent mounting solution, given my own research and the information in this thread.

As far as torque is concerned, the only thing i'm having trouble with is fuel level. I assumed fuel level was reported over OBDII in my car, but Torque does not seem to think so. Has anyone had any luck getting Torque to report fuel level in a GD or GR?
mechatricity is offline   Reply With Quote
Old 03-26-2013, 08:03 PM   #429
imrocksolid
Scooby Newbie
 
Member#: 344254
Join Date: Jan 2013
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
2011 WRX STI
Pearl White

Default

Quote:
Originally Posted by voltic View Post
^ What's that custom home screen deal you have going on? I like it.
It's a photo shopped background. I used UCCW to make "invisible" widgets that I put over the words/buttons.
imrocksolid is offline   Reply With Quote
Old 03-26-2013, 08:40 PM   #430
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

Updated my post with a demo video. I'll release a CWM-flashable and a bootanimation.zip that you can install manually here tonight.

Quote:
Originally Posted by imrocksolid View Post
It's a photo shopped background. I used UCCW to make "invisible" widgets that I put over the words/buttons.
I suspected that's what you did.
voltic is offline   Reply With Quote
Old 03-26-2013, 08:45 PM   #431
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

Quote:
Originally Posted by mechatricity View Post
Has anyone had any luck getting Torque to report fuel level in a GD or GR?
I can't speak for Torque, because it lacks USB support entirely, but I know my car (GR) reports it to DashCommand, so there's definitely a working PID for it somewhere.

Last edited by voltic; 03-27-2013 at 01:05 AM.
voltic is offline   Reply With Quote
Old 03-27-2013, 12:17 AM   #432
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

STi Boot Animation for the Nexus 7



Downloads:
CWM Recovery Flashable ZIP
Manual Install bootanimation.zip File

Thanks to GOFASTSTI at IWSTI for the excellent base image!

I don't currently have any plans of releasing this with other logos (eg., WRX, Subaru), but if enough people want it, I can probably be easily persuaded.

Yes, the spinny loading wheel loops much longer than this when installed.

Last edited by voltic; 03-27-2013 at 12:51 AM.
voltic is offline   Reply With Quote
Old 03-27-2013, 12:34 PM   #433
RobPaulson
Scooby Newbie
 
Member#: 348679
Join Date: Mar 2013
Location: Florida Panhandle
Vehicle:
2013 WRX
Blue

Default

does the GPS react well for navigation? Meaning, is there any kind of delay or trouble connecting to the satellite?

has anyone used a 3g (or some data enabled) tablet? does it being in the dash kill your signal?
RobPaulson is offline   Reply With Quote
Old 03-27-2013, 12:42 PM   #434
RobPaulson
Scooby Newbie
 
Member#: 348679
Join Date: Mar 2013
Location: Florida Panhandle
Vehicle:
2013 WRX
Blue

Default

does the GPS react well for navigation? Meaning, is there any kind of delay or trouble connecting to the satellite?

has anyone used a 3g (or some data enabled) tablet? does it being in the dash kill your signal?
RobPaulson is offline   Reply With Quote
Old 03-27-2013, 01:57 PM   #435
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

A few millimeters of plastic isn't enough to attenuate GPS in any noticeable way, and certainly not mobile data. Everything works fine.
voltic is offline   Reply With Quote
Old 03-27-2013, 03:49 PM   #436
debbinkm
Scooby Newbie
 
Member#: 227167
Join Date: Oct 2009
Location: San Diego, CA
Vehicle:
2011 WRX 5dr
Silver

Default

Thought I'd throw my project up here for anybody who's thinking of doing this. It's not too difficult and I am loving it so far. Nothing too new as far as unique things I did, just took ideas from this thread as well as this thread.

Installed the USB DAC and 4-port hub in today and it sounds awesome. Still want to do some more testing with power (I have
thisthis
soldered onto the 12V switch wire and seems to be doing fine so far at keeping my tablet charged).

I relocated my head unit (Sony single-din) to under the passenger's seat and just use the AUX-in port on that to send sound to the speakers. ASWC Axxess for steering control (volume control mostly, but mute works, too, which is useful).

I'll be glad to answer any questions people have about the setup. Thanks to everyone who did this before me for the inspiration and answering my questions!



debbinkm is offline   Reply With Quote
Old 03-27-2013, 05:58 PM   #437
onsit
Scooby Specialist
 
Member#: 292225
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Rockville, MD
Vehicle:
08 VF52 WRX
OBP

Default

Quote:
Originally Posted by debbinkm View Post
Thought I'd throw my project up here for anybody who's thinking of doing this. It's not too difficult and I am loving it so far. Nothing too new as far as unique things I did, just took ideas from this thread as well as this thread.

Installed the USB DAC and 4-port hub in today and it sounds awesome. Still want to do some more testing with power (I have this soldered onto the 12V switch wire and seems to be doing fine so far at keeping my tablet charged).

I relocated my head unit (Sony single-din) to under the passenger's seat and just use the AUX-in port on that to send sound to the speakers. ASWC Axxess for steering control (volume control mostly, but mute works, too, which is useful).

I'll be glad to answer any questions people have about the setup. Thanks to everyone who did this before me for the inspiration and answering my questions!



I can tell you are using USB Host ROM by Timur? Great ppi adjustment and such from that rom.

A few questions, I have been trying to get OTG + Charging to hook up to a USB hub. But I can seem to work out why it wont charge.

I use:
Amazon.com: StarTech.com Micro USB Cable - A to Right Angle Micro B (UUSBHAUB1RA): ElectronicsAmazon.com: StarTech.com Micro USB Cable - A to Right Angle Micro B (UUSBHAUB1RA): Electronics
And a USB Y power cable... However maybe im not using the right cable.

Mind linking the 2 cables you purchased, and the wiring behind it? Seems like it wont accept power.
onsit is offline   Reply With Quote
Old 03-27-2013, 06:09 PM   #438
debbinkm
Scooby Newbie
 
Member#: 227167
Join Date: Oct 2009
Location: San Diego, CA
Vehicle:
2011 WRX 5dr
Silver

Default

No problem. As I said before, the power is supplied by
this chargerthis charger
(just soldered ground and 12V switch wires to the contacts), then from there it goes:
  1. Startech.com Micro-USB CableStartech.com Micro-USB Cable
  2. Micro USB OTG "Y" CableMicro USB OTG "Y" Cable
  3. Amazon Basics 4-port USB HubAmazon Basics 4-port USB Hub
  4. FiiO E10 USB DACFiiO E10 USB DAC
The other end of the "Y" cable plugs into the tablet, although I had to cut and solder on a 90 deg male because the straight plug didn't provide the clearance needed for the trim to snap back on.

Yeah I'm using Timur's Fixed Install Kernel on top of JDX (13.2 at the moment) and it seems to work great. Make sure you read about how to use the kernel (ie. you have to boot with everything plugged in, etc.). Everything pretty much worked out of the box for me though. Try plugging it into the AC plug that came with your N7 maybe to make sure it's not a problem with the power supplied in your car. Good luck!

Last edited by debbinkm; 03-27-2013 at 06:12 PM. Reason: Lists not formatting correctly...
debbinkm is offline   Reply With Quote
Old 03-27-2013, 06:18 PM   #439
debbinkm
Scooby Newbie
 
Member#: 227167
Join Date: Oct 2009
Location: San Diego, CA
Vehicle:
2011 WRX 5dr
Silver

Default

Also, although I'm not really using the USB Hub yet, I did test plugging in a USB flash stick and mounting it with StickMount and it works fine alongside the USB DAC. Plans are to wire up the USB port that is in the armrest to the hub so that I can just plug a USB stick in there with all my music and update it without taking the dash apart.
debbinkm is offline   Reply With Quote
Old 03-27-2013, 06:35 PM   #440
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

So from what I've had the DAC has to be plugged in at boot to be recognized. Do you have any issues resuming from sleep after turning the car back on with the DAC not being recognized?
voltic is offline   Reply With Quote
Old 03-27-2013, 07:01 PM   #441
debbinkm
Scooby Newbie
 
Member#: 227167
Join Date: Oct 2009
Location: San Diego, CA
Vehicle:
2011 WRX 5dr
Silver

Default

Nope haven't had any issues with that. With Tasker, I just have my tablet turn the screen and WiFi off so I'm not sure if that's what you mean from "sleep". The DAC definitely loses power, but again, no issues reconnecting to the tablet when I turn my car on.
debbinkm is offline   Reply With Quote
Old 03-27-2013, 07:31 PM   #442
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

Interesting. My E10 should be in tomorrow... I really want to make that acrylic box some of you guys have been doing. The metal bar and cork works well but removal and replacement is a bitch. Edit: Ignore what this line used to be if you already read it. I had a derp.

Last edited by voltic; 03-27-2013 at 08:02 PM.
voltic is offline   Reply With Quote
Old 03-27-2013, 07:54 PM   #443
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

Quote:
Originally Posted by onsit View Post
I can tell you are using USB Host ROM by Timur? Great ppi adjustment and such from that rom.

A few questions, I have been trying to get OTG + Charging to hook up to a USB hub. But I can seem to work out why it wont charge.

I use:
Amazon.com: StarTech.com Micro USB Cable - A to Right Angle Micro B (UUSBHAUB1RA): Electronics
And a USB Y power cable... However maybe im not using the right cable.

Mind linking the 2 cables you purchased, and the wiring behind it? Seems like it wont accept power.
My cabling setup:
12VDC 3 Amp USB Regulator from this Ebay seller
IVSO Nexus 7 Tablet Micro USB Host OTG CableIVSO Nexus 7 Tablet Micro USB Host OTG Cable

Apricorn USB Power Adapter Y CableApricorn USB Power Adapter Y Cable


The 3A regulator I use is similar to this one but mine has no micro-USB cable. I went with this so I could be sure that I'd be able to run 4 different devices at 500mA (will never actually happen) and still be able to have 1A dedicated to the Nexus 7.

Setup:
Regulator gets the male grey side of the Y-cable (power only) plugged into it.
Nexus 7 gets the female OTG cable plugged into it.
OTG cable gets male black side of the Y-cable plugged into it.
Female end of the Y-cable gets the USB hub plugged into it.

Regulator gets attached to switched 12v. Done.

I run Timur's full fixed installation ROM. I see no reason to run anything else since it's just a CM10 base with some added features in all the right places.
voltic is offline   Reply With Quote
Old 03-27-2013, 10:25 PM   #444
Andrew025
Scooby Specialist
 
Member#: 303408
Join Date: Dec 2011
Chapter/Region: NWIC
Location: Portland, Or
Vehicle:
04 STi
WRB

Default

Quote:
Originally Posted by voltic View Post

I run Timur's full fixed installation ROM. I see no reason to run anything else since it's just a CM10 base with some added features in all the right places.
Since the USB DAC has to be plugged in at boot, do you know if the same applies to just using power + USB otg flash drive? I've been having a hell of a time with one of faux's kernels to get power + usb otg support.
Andrew025 is offline   Reply With Quote
Old 03-28-2013, 04:57 AM   #445
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

Charging with OTG enabled isn't an option in most ROMs, you should check to see if faux supports that. I went with Timur because there is no question and this is what it was built for. I haven't really dealt much with external drives and OTG. I'll probably be getting a flash drive here soon for it.
voltic is offline   Reply With Quote
Old 03-28-2013, 05:08 AM   #446
Andrew025
Scooby Specialist
 
Member#: 303408
Join Date: Dec 2011
Chapter/Region: NWIC
Location: Portland, Or
Vehicle:
04 STi
WRB

Default

Quote:
Originally Posted by voltic View Post
Charging with OTG enabled isn't an option in most ROMs, you should check to see if faux supports that. I went with Timur because there is no question and this is what it was built for. I haven't really dealt much with external drives and OTG. I'll probably be getting a flash drive here soon for it.
Charging and OTG does work with faux kernel, it's just a pain in the ass with making sure things are plugged in the correct order and such.
I was mostly wondering if it happened to be implemented a little better with the Timur ROM.
Andrew025 is offline   Reply With Quote
Old 03-28-2013, 10:24 AM   #447
debbinkm
Scooby Newbie
 
Member#: 227167
Join Date: Oct 2009
Location: San Diego, CA
Vehicle:
2011 WRX 5dr
Silver

Default

I went straight to the Timur kernel with mine (just because I was most familiar with it - hadn't heard of Faux kernel). Everything worked well as long as it was plugged in at boot. I even tried plugging in a USB flash drive after boot into the 4 port USB hub and it was recognized right away with StickMount.

Anyway, I would give Timur kernel a shot. It takes 5 seconds to flash a kernel and 5 seconds to go back if it doesn't work for you.

Also, I tried Timur's ROM (which is basically CM10.1 with Timur kernel) and it was okay, but JDX 13.2 with Timur's fixed install kernel seems more stable to me.
debbinkm is offline   Reply With Quote
Old 03-28-2013, 12:00 PM   #448
onsit
Scooby Specialist
 
Member#: 292225
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Rockville, MD
Vehicle:
08 VF52 WRX
OBP

Default

Also, seems like Torque can now recognize USB OBD2 devices....

Curious if a Tactrix cable can be used as the connecting interface! Bluetooth is just too slow for engine updates.
onsit is offline   Reply With Quote
Old 03-28-2013, 07:13 PM   #449
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

Quote:
Originally Posted by Andrew025 View Post
Charging and OTG does work with faux kernel, it's just a pain in the ass with making sure things are plugged in the correct order and such.
I was mostly wondering if it happened to be implemented a little better with the Timur ROM.
I've never had to tinker with orders of plugging things in.

Quote:
Originally Posted by debbinkm View Post
I went straight to the Timur kernel with mine (just because I was most familiar with it - hadn't heard of Faux kernel). Everything worked well as long as it was plugged in at boot. I even tried plugging in a USB flash drive after boot into the 4 port USB hub and it was recognized right away with StickMount.

Anyway, I would give Timur kernel a shot. It takes 5 seconds to flash a kernel and 5 seconds to go back if it doesn't work for you.

Also, I tried Timur's ROM (which is basically CM10.1 with Timur kernel) and it was okay, but JDX 13.2 with Timur's fixed install kernel seems more stable to me.
How was the ROM unstable? I like it because of options that go beyond the kernel.

Quote:
Originally Posted by onsit View Post
Also, seems like Torque can now recognize USB OBD2 devices....

Curious if a Tactrix cable can be used as the connecting interface! Bluetooth is just too slow for engine updates.
Yeah, I had Torque up and running last night over USB OBDLink... it was working great, way more responsive than DashCommand, like damn near instant feedback, but now it's not connecting. Android recognizes the device and launches Torque but then Torque says it can't connect. I really dislike the way these Torque gauges look, too. They're small and difficult to read, have you guys found a good skin?
voltic is offline   Reply With Quote
Old 03-28-2013, 08:01 PM   #450
mechatricity
Scooby Specialist
 
Member#: 290592
Join Date: Aug 2011
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
04 WRX Wagon,
15 WRX 6MT CWP

Default

Quote:
Originally Posted by voltic View Post
I've never had to tinker with orders of plugging things in.



How was the ROM unstable? I like it because of options that go beyond the kernel.



Yeah, I had Torque up and running last night over USB OBDLink... it was working great, way more responsive than DashCommand, like damn near instant feedback, but now it's not connecting. Android recognizes the device and launches Torque but then Torque says it can't connect. I really dislike the way these Torque gauges look, too. They're small and difficult to read, have you guys found a good skin?
The gauge size in Torque is customize-able.
mechatricity is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.