Welcome to the North American Subaru Impreza Owners Club Sunday August 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-10-2013, 01:00 PM   #201
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by zedix View Post
Haha I feel your pain! I used GorillaGlue to bond the spacers to the aluminium bracket. Didn't even sand them down. GorillaGlue glues everything!

Glad to see all the projects progressing nicely!

As for notifications - on my Nexus 7 when listening to music (via Google Music or Tune In), the sound dims down slightly, the notification tone plays, then the sound fades back in. Pretty slick. Is that not what you're experiencing?
oh no... that's exactly what it's doing... and exactly what i don't want. i want the notifications to come out of the tablet speakers and not interfere with my music playback. it's already interrupted a crucial karaoke moment. i may just turn notifications off.
* Registered users of the site do not see these ads.
sabregen is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-10-2013, 01:03 PM   #202
zedix
Scooby Newbie
 
Member#: 336913
Join Date: Nov 2012
Chapter/Region: E. Canada
Vehicle:
2010 Impreza Ltd

Default

Quote:
Originally Posted by rkl303 View Post
Sorry should have been more clear. I was referring to the trablet and the cork(possibly the bezel) I don't see any pictures of velcro something to hold it up.
The tablet rests against the cork purely on compression. I had a whole system with industrial velcro to hold it up, but didn't end up needing it. The trimming done to the bezel and cork makes it so the two hold up perfectly without any adhesives needed. Gotta keep it simple
zedix is offline   Reply With Quote
Old 01-10-2013, 01:03 PM   #203
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by zedix View Post
Interesting... I'm not sure this would help us. If the wiring in the car and 12v to 5v converter only outputs <1A, I'm not sure how this gadget could multiply the current.

I finally got my new (supposedly) 12V-5V 3A buck converter from China. I've been lazy and haven't yet soldered it in because everything works so well, but I'll probably do it this weekend and report back with the part # if it works well!

mine is working awesomely. although, admittedly i cannot seem to find the screen that you pictured in battery monitor. that side by side usage versus charge screen with the report on mA used and mA being charged. i've looked and looked. i'd like to know my actual numbers.
sabregen is offline   Reply With Quote
Old 01-10-2013, 01:04 PM   #204
zedix
Scooby Newbie
 
Member#: 336913
Join Date: Nov 2012
Chapter/Region: E. Canada
Vehicle:
2010 Impreza Ltd

Default

Quote:
Originally Posted by sabregen View Post
oh no... that's exactly what it's doing... and exactly what i don't want. i want the notifications to come out of the tablet speakers and not interfere with my music playback. it's already interrupted a crucial karaoke moment. i may just turn notifications off.
Just a hunch, but you could probably achieve what you want with Tasker.

On {Google Music App Launched}
- Set Notification volume = 0
zedix is offline   Reply With Quote
Old 01-10-2013, 01:05 PM   #205
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by rkl303 View Post
Sorry should have been more clear. I was referring to the trablet and the cork(possibly the bezel) I don't see any pictures of velcro something to hold it up.
the tablet is sandwiched between the cork on the aluminum horizontal bracing and the back of the dash piece. this is a compression fit as well.

zedix - what do you have holding the bottom of the tablet in place, and do you have any issues with the bottom of the tablet contacting (and pushing) the JVC HU's click-wheel (which changes inputs when pressed)?
sabregen is offline   Reply With Quote
Old 01-10-2013, 01:06 PM   #206
zedix
Scooby Newbie
 
Member#: 336913
Join Date: Nov 2012
Chapter/Region: E. Canada
Vehicle:
2010 Impreza Ltd

Default

Quote:
Originally Posted by sabregen View Post
zedix - what do you have holding the bottom of the tablet in place, and do you have any issues with the bottom of the tablet contacting (and pushing) the JVC HU's click-wheel (which changes inputs when pressed)?
The bottom of the tablet just sits on top of the air vents... it's such a tight fit around the bezel that everything holds nicely. Seriously I could not have planned the dimensions better haha!

No pushing the JVC HU's click-wheel, never happened for me. There's a solid inch between the back of the tablet and the click-wheel.
zedix is offline   Reply With Quote
Old 01-10-2013, 01:09 PM   #207
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by zedix View Post
Just a hunch, but you could probably achieve what you want with Tasker.

On {Google Music App Launched}
- Set Notification volume = 0
I am having some trouble with tasker. I can't even get the basic crap to work. the whole

on {power connect}
-set screen ON
-turn BT ON
-turn wireless ON

on {power disconnect}
-set screen OFF
-turn BT OFF
-turn wireless OFF

it doesn't really seem to care. Tasker is running. i don't get it.
sabregen is offline   Reply With Quote
Old 01-10-2013, 01:24 PM   #208
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

screw it. unlocked developer, screen on while charging. set sleep in tasker to 15 second timeout when not charging.
sabregen is offline   Reply With Quote
Old 01-10-2013, 01:27 PM   #209
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by zedix View Post
The bottom of the tablet just sits on top of the air vents... it's such a tight fit around the bezel that everything holds nicely. Seriously I could not have planned the dimensions better haha!

No pushing the JVC HU's click-wheel, never happened for me. There's a solid inch between the back of the tablet and the click-wheel.
interesting. there's definitely not an inch between the bottom of my nexus 7 and the click wheel. i suspect the difference in HU's leads to my increase depth front to back. so on yours the cork is forcing the top half of the tablet to butt up against the rear of the front dash piece and it's just holding there? nothing on the bottom? did you shave the cork (on the front where it meets the tablet) at an angle to match the back of the nexus 7's rested position?
sabregen is offline   Reply With Quote
Old 01-10-2013, 03:03 PM   #210
rkl303
Scooby Newbie
 
Member#: 171314
Join Date: Feb 2008
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2008 STI
OBP

Default

Hopefully my last question (ordered the bezel last night and now I gotta find a nexus 32gb for cheap or wait until the next gen comes out hopefully w/ FM support) but when you shaved the bezel did you just shave the tabs a little or did you shave any of the material that the screen actualy rests against so that the nexus sits closer to the driver...I'll post a pic up shortly.
rkl303 is offline   Reply With Quote
Old 01-10-2013, 03:12 PM   #211
rkl303
Scooby Newbie
 
Member#: 171314
Join Date: Feb 2008
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2008 STI
OBP

Default



Did you guys shave any of the area i highlighted in green. Would have included the horizontal sections as well just didnt bother too.
rkl303 is offline   Reply With Quote
Old 01-10-2013, 03:40 PM   #212
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

negative. all of the shaving was done on the back side only, on the clips that lock the directional vents into place, and on the tabs that lock this new dash face into the rest of the dash. don't worry, it's easier seen in person than explained. all you'll have to do is try to put the nexus 7 inside of the new dash and you'll immediately see what we're talking about.
sabregen is offline   Reply With Quote
Old 01-10-2013, 06:23 PM   #213
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

i have fixed the metra axxess awsc issues by manually programming. did another coat of plasti-dip (drying now) to touch upa few places where pulling the dash off and on had come up a bit on the edges. i finally have a good test fit on the pieces of cork... that was a lot of work.

zedix - does the bottom of your Nexus 7 meet flush with the new dash piece? mine doesn't. it sits about 1/4" back. i'd like to fix that, but other than taping the nexus to the dash piece, i'm not sure how best to tackle this.
sabregen is offline   Reply With Quote
Old 01-10-2013, 09:34 PM   #214
onsit
Scooby Specialist
 
Member#: 292225
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Rockville, MD
Vehicle:
08 WRX (16g)
OBP

Default

The 12v to 5v usb converter seems to output only 500ma, and it's visible to the system as a "usb charger"

Now.. I dont feel like ripping up the converted and sodering the 2 data wires into 1 wire, causing Android to think it is a Power Source only mode.

Is there a rooted kernel available that forces all charging to AC MODE?
onsit is online now   Reply With Quote
Old 01-10-2013, 10:10 PM   #215
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by onsit View Post
The 12v to 5v usb converter seems to output only 500ma, and it's visible to the system as a "usb charger"

Now.. I dont feel like ripping up the converted and sodering the 2 data wires into 1 wire, causing Android to think it is a Power Source only mode.

Is there a rooted kernel available that forces all charging to AC MODE?
which unit are you referring to?
sabregen is offline   Reply With Quote
Old 01-10-2013, 10:29 PM   #216
onsit
Scooby Specialist
 
Member#: 292225
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Rockville, MD
Vehicle:
08 WRX (16g)
OBP

Default

Quote:
Originally Posted by sabregen View Post
which unit are you referring to?
The CPT 12v to 5v USB converter off Amazon.

Obviously Android won't recognize it as an "AC" charging device, but a "USB" charging device. Thus limiting how much it will actually charge.

Kernel patches are available on most Android devices to force all charging into "AC" mode. However I havent found a stable kernel that supports this property on the Nexus 7.

Might need to hardwire it to be power only, as opposed to data.
onsit is online now   Reply With Quote
Old 01-10-2013, 10:40 PM   #217
rkl303
Scooby Newbie
 
Member#: 171314
Join Date: Feb 2008
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2008 STI
OBP

Default

Quote:
Originally Posted by onsit View Post
The 12v to 5v usb converter seems to output only 500ma, and it's visible to the system as a "usb charger"

Now.. I dont feel like ripping up the converted and sodering the 2 data wires into 1 wire, causing Android to think it is a Power Source only mode.

Is there a rooted kernel available that forces all charging to AC MODE?
That's dissappointing.
rkl303 is offline   Reply With Quote
Old 01-11-2013, 10:14 AM   #218
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

this one, correct?
Amazon.com: SZD Dc Converter Buck Module 12v Convert to 5v,5v Usb Output Power Adapter Top NEW: ElectronicsAmazon.com: SZD Dc Converter Buck Module 12v Convert to 5v,5v Usb Output Power Adapter Top NEW: Electronics

that does suck. it says right on there 5v/3A max. i guess they really mean MAX, not RMS.

what are you using to measure voltage output?
sabregen is offline   Reply With Quote
Old 01-11-2013, 10:23 AM   #219
onsit
Scooby Specialist
 
Member#: 292225
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Rockville, MD
Vehicle:
08 WRX (16g)
OBP

Default

Quote:
Originally Posted by sabregen View Post
this one, correct? Amazon.com: SZD Dc Converter Buck Module 12v Convert to 5v,5v Usb Output Power Adapter Top NEW: Electronics

that does suck. it says right on there 5v/3A max. i guess they really mean MAX, not RMS.

what are you using to measure voltage output?
It outputs 2.8amps just fine. It's just Android has a software limited on it, if it detects power current on the data pins of the usb.

So the pins need to be hardwired, or a software patch needs to be applied.
onsit is online now   Reply With Quote
Old 01-11-2013, 11:40 AM   #220
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by onsit View Post
It outputs 2.8amps just fine. It's just Android has a software limited on it, if it detects power current on the data pins of the usb.

So the pins need to be hardwired, or a software patch needs to be applied.
interesting. how can I confirm that this isn't happening on my device. How are you measuring this on the Nexus 7?
sabregen is offline   Reply With Quote
Old 01-11-2013, 12:34 PM   #221
onsit
Scooby Specialist
 
Member#: 292225
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Rockville, MD
Vehicle:
08 WRX (16g)
OBP

Default

Quote:
Originally Posted by sabregen View Post
interesting. how can I confirm that this isn't happening on my device. How are you measuring this on the Nexus 7?
under the battery monitoring widget.

Notice if you use the OEM charger, connected to a wall. It will display you are charging at 1800-1600 mA. This means you are charging at 1600 and the system is using 1200 so its 3000 - 1200 = 1600 to 1800 actually charging the device.

Plug it into your car moded charger. It will say charging -500mA meaning that it's not charging at full capactiy.
onsit is online now   Reply With Quote
Old 01-11-2013, 12:40 PM   #222
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

i wish i knew how to read that damned app. can someone take a screenshot and draw picture on it so i know what the hell i'm looking at? i'm not a noob on electronics, i just don't understand how they've laid out the GUI.

makes no sense to me. don't know what my charge rate is, and my usage rate. that's all i care about.
sabregen is offline   Reply With Quote
Old 01-11-2013, 12:41 PM   #223
claythrow
Scooby Specialist
 
Member#: 283663
Join Date: May 2011
Chapter/Region: NESIC
Location: Boston
Vehicle:
2004 STI
Root Beer

Default

I'm working on a Nexus 7 installation right now in an 800 HP Pantera. Custom dash which is just about ready, not exactly sure where the Nexus is going at the moment, probably in the center dash under the vents (above but in front of the shifter) which has not been fabricated yet. But I'll post final pictures when the install is done. This is the hardest install I've ever been involved with because there is just no room in the car. It's a mid engine mid 80's super car. I'm 5'9" and the roofline doesn't even come up to my waist. There are no kick panel areas because the wheel wells come that far back. I can't imagine what it is like to drive/race it with the balance it has being mid engine and putting down 800hp at the wheels and the wheel base it has, but installing a system…it's like trying to install a system in a toaster. Credit for the fabrication and the whole car build goes to Pat at P.A.T. (Performance Automotive Technology) in Tyngsboro MA. www.patsauto.com Home of the best engine builder I've ever met, and just an insane shop (really poke around the site for pictures) Even the owner Pat although a normal functioning human being and socially quite normal is actually off his rocker. And by that I mean you have to be some form of crazy to put the time, care and attention to detail into your product that this place does. I have that kind of crazy too, however I don't have the genius, talent or experience this place does. The cars he builds, the motors they turn out…the knowledge inside those walls eclipses anything I've ever seen in any field or business. Enough of that talk, I just remembered he may actually read this as we consult on the nexus install but here are some pics of the car. I have more but this is his property and I don't want to post something he doesn't want on the net.



The engine


Last edited by claythrow; 01-11-2013 at 01:48 PM.
claythrow is offline   Reply With Quote
Old 01-11-2013, 12:46 PM   #224
sabregen
Scooby Newbie
 
Member#: 338852
Join Date: Nov 2012
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2013 WRX Premium
WR Blue

Default

Quote:
Originally Posted by claythrow View Post
I'm working on a Nexus 7 installation right now in an 800 HP Pantera. Custom dash which is just about ready, not exactly sure where the Nexus is going at the moment, probably in the center dash under the vents (above but in front of the shifter) which has not been fabricated yet. But I'll post final pictures when the install is done

i also have a 2WD drive vehicle. 88 porsche 911 triple black whale tail. and nobody cares about my 2wd car either.

sabregen is offline   Reply With Quote
Old 01-11-2013, 01:16 PM   #225
Buildscharacter
Scooby Newbie
 
Member#: 322223
Join Date: Jun 2012
Default

A thanks to Zedix and sabregen for doing a lot of the legwork here.

I've been playing around with my Nexus 7 and installed it into my car as the others have done. I grabbed myself a 3A 12v->5v converter off ebay (http://www.ebay.com/itm/waterproof-D.../271107526766?) and installed that.

Everything was working really well for me, I had tasker going, the tablet was turning on when the power would go on, but even with turning everything off (wifi, GPS, screen, bluetooth) I was having charging issues. My commute to work is only about 10 minutes and it just wasn't enough time to keep it charged. Over the course of the week I was losing around 5% battery a day.

I wired the charger into the yellow "always on" wire in the harness and that works, but now I am battling with how to make it turn on and off with the car. I've though about using Tasker to look at GPS, but that doesn't help me when I go somewhere unplanned (read: not my house or work). I thought of using my bluetooth on my phone, but I don't like relying on my phone to turn it on and off. My next test is going to be a NFC sticker that I have on my keychain. That way I can get in the car, touch my keys to the tablet and start the car as the tablet is turning on and connecting. The other idea I had was to mount a discrete switch somewhere so that I could manually cut the power to the tablet.

I just read about the change to the bootloader that Zedix found over at XDA, so that makes me wonder if I could just apply that so that there's 0% power drain when it's not powered... that could be a workable option as well.

I'm waiting on my JDM bezel to come in, so it gives me time to play around with different options before getting it permanently installed.
Buildscharacter is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.