Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-26-2012, 03:24 PM   #1
Rexasaurus
Scooby Newbie
 
Member#: 337723
Join Date: Nov 2012
Chapter/Region: RMIC
Location: Fort Collins, CO
Vehicle:
2004 WRX
WRB

Default New to Forums! Pictures Inside! Misfiring 04 Rex

Hey Everyone, My name is Mike and I'm moving over here from rs25.com after selling my rs and picking up a 2004 WRX. The car has given me plenty of headaches since I've bought it so I plan on spending plenty of time on here trying to get her running right. I live in Fort Collins, Colorado and am looking to get more active in the Subaru Community!






* Registered users of the site do not see these ads.

Last edited by Rexasaurus; 11-26-2012 at 09:25 PM. Reason: Trying to figure out Picture Uploading- Added Details
Rexasaurus is offline   Reply With Quote
Old 11-26-2012, 03:36 PM   #2
findurpath
Scooby Specialist
 
Member#: 277487
Join Date: Mar 2011
Chapter/Region: NWIC
Location: Bozeman, MT and Lakewood, WA
Vehicle:
2006 CGM WRX Limited
6sp, 18G, Phatron tuned

Default

Welcome!
findurpath is offline   Reply With Quote
Old 11-26-2012, 03:38 PM   #3
Daniel_DeWitt
Scooby Newbie
 
Member#: 325029
Join Date: Jul 2012
Vehicle:
2002 Impreza 2.5RS
Midnight Black

Default

Those are huge wheels
Daniel_DeWitt is offline   Reply With Quote
Old 11-26-2012, 03:44 PM   #4
Mr Wrex
Scooby Specialist
 
Member#: 332887
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Orange County, NY
Vehicle:
2012 WRX stage 2+
DGM (sedan)

Default

^ this

What problems did you run into btw?
Mr Wrex is offline   Reply With Quote
Old 11-26-2012, 03:47 PM   #5
jay25RS
Scooby Specialist
 
Member#: 4273
Join Date: Feb 2001
Chapter/Region: NESIC
Location: CT
Vehicle:
2011 GR-STI
& 2015 Legacy Ltd.

Default

Quote:
Originally Posted by Daniel_DeWitt View Post
Those are huge wheels
They look like stock GH/GR WRX wheels.

Welcome to Rexasaurus!
jay25RS is online now   Reply With Quote
Old 11-26-2012, 04:56 PM   #6
Gallo2011
Scooby Guru
 
Member#: 268310
Join Date: Dec 2010
Chapter/Region: SCIC
Location: So Kali
Vehicle:
2011 SSM STI saloon
Church!

Default

That first picture makes me skeered.
Gallo2011 is offline   Reply With Quote
Old 11-26-2012, 06:58 PM   #7
Rexasaurus
Scooby Newbie
 
Member#: 337723
Join Date: Nov 2012
Chapter/Region: RMIC
Location: Fort Collins, CO
Vehicle:
2004 WRX
WRB

Default

Quote:
Originally Posted by jay25RS View Post
They look like stock GH/GR WRX wheels.

Welcome to Rexasaurus!
Thanks! and yep they're off of a 2008 WRX Sedan
Rexasaurus is offline   Reply With Quote
Old 11-26-2012, 07:05 PM   #8
Rexasaurus
Scooby Newbie
 
Member#: 337723
Join Date: Nov 2012
Chapter/Region: RMIC
Location: Fort Collins, CO
Vehicle:
2004 WRX
WRB

Default

Quote:
Originally Posted by Mr Wrex View Post
^ this

What problems did you run into btw?
The car sputters/ hesitates / bucks under boost and consistently throws a cylinder 1 and 2 miss fire code with a blinking cel. Once I have enough posts I'll start a new thread with details!

I have spent countless hours trying to diagnose this with no success, it's at the dealership now for a leak down and compression test. I'll be sure to post the results, keeping my fingers crossed
Rexasaurus is offline   Reply With Quote
Old 11-26-2012, 08:29 PM   #9
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

You can post all the details here.....
HinshawWRX is offline   Reply With Quote
Old 11-26-2012, 09:21 PM   #10
Rexasaurus
Scooby Newbie
 
Member#: 337723
Join Date: Nov 2012
Chapter/Region: RMIC
Location: Fort Collins, CO
Vehicle:
2004 WRX
WRB

Default Misfire Help Please!??


Last edited by Rexasaurus; 11-27-2012 at 01:21 PM. Reason: Cross Post in 2.0L Powertrain Forum
Rexasaurus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.