Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-07-2012, 01:23 PM   #26
luciferMotorCade
Scooby Newbie
 
Member#: 253611
Join Date: Jul 2010
Chapter/Region: NWIC
Location: the couve
Vehicle:
2004 GeNOME
WRB

Default

hey TAKE YOUR CAR TO A MECHANIC WHO CHARGES.


pg 2 PWND
* Registered users of the site do not see these ads.
luciferMotorCade is offline   Reply With Quote
Old 12-07-2012, 02:41 PM   #27
Stangy
Scooby Newbie
 
Member#: 329676
Join Date: Aug 2012
Chapter/Region: E. Canada
Location: Canada
Vehicle:
1999 GC8 R-STI
White

Default

Quote:
Originally Posted by luciferMotorCade View Post
this is true. fxt05 and I have had more problems with our subies than my 28yr old vw. only issue was the cold start injector fuel line had a small hole in it. never left me stranded like our subies.
you have any build threads on your cars?
Somwhere lol
Stangy is offline   Reply With Quote
Old 12-07-2012, 08:47 PM   #28
fxt05
Scooby Newbie
 
Member#: 208521
Join Date: Apr 2009
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
'96 STI Type RA
'05 FXT

Default

Changed the plugs and cleaned the maf but when I was putting everything back together I broke a nipple off part of the intake. Of course the dealer wasn't able to find this part so looks like jb weld will be the temp fix till I can get it running then I'll be upgrading to the apexi intake.

Tomorrow I'll be putting it back together to see if the plugs helped. Then I'll be checking the maf. Then changing the fuel filter again to see if that magically helps, if not I'll be checking the cat to see if its plugged.

Anyone have any other suggestions of what my problem might be?

How can I test the COP's to make sure they're good?
fxt05 is offline   Reply With Quote
Old 12-07-2012, 11:58 PM   #29
Stangy
Scooby Newbie
 
Member#: 329676
Join Date: Aug 2012
Chapter/Region: E. Canada
Location: Canada
Vehicle:
1999 GC8 R-STI
White

Default

Plugs. Injectors
Stangy is offline   Reply With Quote
Old 12-08-2012, 04:50 PM   #30
fxt05
Scooby Newbie
 
Member#: 208521
Join Date: Apr 2009
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
'96 STI Type RA
'05 FXT

Default

Changed the plugs, cleaned the maf. Ran great for a couple miles. It starts stuttering when I cruise at a steady speed. if I push in the clutch and rev it stops for a little bit.

I think I'll try cleaning the iacv. Does it sound like it may be this?

Edit: it also happens after idling at a light for a little while.

Last edited by fxt05; 12-08-2012 at 05:28 PM.
fxt05 is offline   Reply With Quote
Old 02-22-2013, 06:08 PM   #31
fxt05
Scooby Newbie
 
Member#: 208521
Join Date: Apr 2009
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
'96 STI Type RA
'05 FXT

Default

I think I finally fixed it. Cleaning the maf did not help but changing it sure seems to have. These things are expensive new but its fixed.
fxt05 is offline   Reply With Quote
Old 02-27-2013, 06:32 PM   #32
V62.5rssti
Scooby Newbie
 
Member#: 348501
Join Date: Feb 2013
Default

Yep they are pricey
V62.5rssti is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.