Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-02-2012, 11:59 PM   #1
HawkEyeDelight
Scooby Newbie
 
Member#: 312052
Join Date: Mar 2012
Default HELP High Oil Pressure

So i have an 06 wrx which is stage 2 and has Prosport gauges, well when i bought the car my oil pressure gauge was not working (before starting the car it would read 100 psi and never moved ever) and was dripping a miniscule amount of oil from the sender unit. I finally got some money and decided to fix it so i got a new sender unit, filter and rotella t6 oil 5w40. Well once the car is fully warmed up its at like 30 psi at idle and the second i start to drive it jumps to 100 psi and never fluctuates. Please someone help me!!!
* Registered users of the site do not see these ads.
HawkEyeDelight is offline   Reply With Quote
Old 12-03-2012, 02:25 AM   #2
Coreycarlile911
Scooby Specialist
 
Member#: 282614
Join Date: May 2011
Chapter/Region: NWIC
Location: Spokane Washington
Vehicle:
2006 Wrx sti
Black pearl

Default

Sounds bout right
Coreycarlile911 is offline   Reply With Quote
Old 12-03-2012, 07:19 AM   #3
git_sum
Scooby Newbie
 
Member#: 303339
Join Date: Dec 2011
Location: Kentucky
Vehicle:
2006 Saab 9-2x
Red

Default

mine runs around 70 while it's cold or i'm driving and around 30 when it's warm and i stop at a light or something...
git_sum is offline   Reply With Quote
Old 12-03-2012, 10:15 AM   #4
car_freak85
Scooby Specialist
 
Member#: 13530
Join Date: Dec 2001
Chapter/Region: NWIC
Location: Cascadia
Vehicle:
EA63 , EA81T, EG33,
EJ205

Default

This is normal. Pressure is high on startup or while driving. If it goes above 100 or 120 psi, there is a bypass inside the oil pump.

Relax, you're fine.
car_freak85 is offline   Reply With Quote
Old 12-03-2012, 05:59 PM   #5
mechatricity
Scooby Specialist
 
Member#: 290592
Join Date: Aug 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2006 WRX Wagon
2004 WRX Wagon

Default

Normal. My 06 with RT6- 110-115 when cold, 95 under cruise when hot, 30 at idle when hot.
mechatricity is offline   Reply With Quote
Old 12-03-2012, 08:33 PM   #6
HawkEyeDelight
Scooby Newbie
 
Member#: 312052
Join Date: Mar 2012
Default

Thanks alot guys, I saw a bunch of posts with people saying 20 pounds at idle and like 50-60 pounds cruising so when I saw 100 pounds on the high way I freaked
HawkEyeDelight is offline   Reply With Quote
Old 12-03-2012, 08:38 PM   #7
HawkEyeDelight
Scooby Newbie
 
Member#: 312052
Join Date: Mar 2012
Default

Quote:
Originally Posted by git_sum View Post
mine runs around 70 while it's cold or i'm driving and around 30 when it's warm and i stop at a light or something...

So I know I'm probably just being paranoid but your getting 70 while driving and 30 at idle, but I'm running 100 while driving no matter how low the rpms. Sorry if I'm asking too much just don't want to blow my seals or something.
HawkEyeDelight is offline   Reply With Quote
Old 12-03-2012, 08:51 PM   #8
dangerousatom
Scooby Specialist
 
Member#: 70710
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Quakertown/AREA1320 391whp
Vehicle:
2002 04STi Swaped RS
w/PPGS & 02 Wagon w/PPGs

Default

100+psi is normal when your foot is anywhere on the gas psi. Idle should be anywhere from 30ish-50psi depending on oil temp/viscosity/new-old oil/motors warm or cold.

Different pumps sizes make different oil presure too.
-10mm is usually just under 100psi
-11mm the WRX standard pump is around 100+psi
-12mm JDM type is 110-115+psi
All of their pressures drop down to 30-50 like mentioned above
dangerousatom is offline   Reply With Quote
Old 12-03-2012, 09:12 PM   #9
HawkEyeDelight
Scooby Newbie
 
Member#: 312052
Join Date: Mar 2012
Default

Quote:
Originally Posted by dangerousatom View Post
100+psi is normal when your foot is anywhere on the gas psi. Idle should be anywhere from 30ish-50psi depending on oil temp/viscosity/new-old oil/motors warm or cold.

Different pumps sizes make different oil presure too.
-10mm is usually just under 100psi
-11mm the WRX standard pump is around 100+psi
-12mm JDM type is 110-115+psi
All of their pressures drop down to 30-50 like mentioned above
Thank you so much I was deffinatly worried about it but you guys saved the day gotta love nasioc for this kind of stuff
HawkEyeDelight is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.