Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-29-2011, 05:16 AM   #1
subadupa
Scooby Newbie
 
Member#: 166557
Join Date: Dec 2007
Chapter/Region: MWSOC
Location: Dayton, Ohio
Vehicle:
2004 WRB STI
FP HTA68 on E85

Default Oil pressure question

I just installed a new oil pressure gauge and I am seeing readings of 100 psi at cold start idle and 20 ish psi at warm idle. it's between 60-80 psi while driving. Does that seem correct?
* Registered users of the site do not see these ads.
subadupa is offline   Reply With Quote
Old 05-29-2011, 05:19 AM   #2
NJ_wrx
Scooby Newbie
 
Member#: 268855
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2009 WRX
red

Default

That's dead on balls accurate, brotha. Enjoy the gauge!
NJ_wrx is offline   Reply With Quote
Old 05-29-2011, 07:43 PM   #3
subadupa
Scooby Newbie
 
Member#: 166557
Join Date: Dec 2007
Chapter/Region: MWSOC
Location: Dayton, Ohio
Vehicle:
2004 WRB STI
FP HTA68 on E85

Default

Thanks man.
subadupa is offline   Reply With Quote
Old 12-03-2012, 04:03 PM   #4
wagonsarewinners
Scooby Newbie
 
Member#: 337730
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston area
Vehicle:
2007 WRX Wagon
Urban Grey Metallic

Default

Quote:
Originally Posted by subadupa View Post
I just installed a new oil pressure gauge and I am seeing readings of 100 psi at cold start idle and 20 ish psi at warm idle. it's between 60-80 psi while driving. Does that seem correct?

Just curious, what gauge did you install?
wagonsarewinners is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure Question WRB Factory 2.0L Turbo Powertrain 2 04-01-2004 08:53 PM
Oil pressure question FryRice Newbies & FAQs 7 01-04-2004 11:25 PM
oil pressure question jetsiphon Factory 2.0L Turbo Powertrain 3 02-20-2003 01:29 PM
Oil Pressure Question mav1c Factory 2.0L Turbo Powertrain 11 04-11-2002 11:17 PM
('93-'01) Oil pressure question... Buttsy Impreza Forum 10 06-03-2001 10:19 AM


All times are GMT -4. The time now is 09:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.