Welcome to the North American Subaru Impreza Owners Club Sunday July 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-07-2012, 08:36 PM   #26
johnyquest
Scooby Newbie
 
Member#: 258723
Join Date: Sep 2010
Lightbulb

Quote:
Originally Posted by Leafy View Post
Yeah its 3/4. Get a uni-bit, and only go 80% of the way through with the 3/4" step size so you have a nice lip to set the bung on when you weld it so it doesnt fall through.
It can't fall through if I drill it the right size ... the bung itself is stepped.
______________
|....................|
|_................._|
...|_________|

Like that, if there's any chance the formatting stays. DOH. Or I could always just take a picture ... haha, waste of time ascii art:

* Registered users of the site do not see these ads.
johnyquest is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-07-2012, 08:46 PM   #27
johnyquest
Scooby Newbie
 
Member#: 258723
Join Date: Sep 2010
Default

Quote:
Originally Posted by Uncle Scotty View Post
100 miles may not have been enough if you didnt clean it out before you installed it

but you need group n or better engine mounts or a real header or both, in any event
haha, the header is plenty real ... it's just got the bung in the wrong place -- and the price was right ($0) so I'm not complaining, even if it needs some customization.

and HRMM ... what's that suspicious looking upper up-pipe bung I never noticed until looking at a picture of the build? I remember tightening that bolt and kind of recall it being rather small ... but why would that be there...!? Too bad it wasn't 02 sized, I'd throw it in there.

(pic):


Wish I'd known about the engine mounts BEFORE I put the motor in, lol -- They looked to be in good shape -- the car (chassis) only has 58k on the clock, as I believe it's spent most of it's time blown up

No cheap fixes for Subie mounts like urethane inserts (or caulking-gun urethane filling like we used to do for hondas)?

Edit:
While we're on the subject-- Did I miss something when I put this motor in or is the entire thing seriously held in place by TWO nuts and that dog-bone mount I put up top? I keep feeling like any high HP cars would rip the drivers side nut & washer right through the frame...!?

Last edited by johnyquest; 12-07-2012 at 08:54 PM.
johnyquest is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.