Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-02-2012, 05:52 PM   #1
Mekks
Scooby Specialist
 
Member#: 219749
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Upstate NY
Default 02 WRX Strange Noise (video)

Was driving to work today when my car decided to start making this really funny noise. I made a video of it in hopes someone could point me in the right direction.

Please Please Please tell me its not internal.

* Registered users of the site do not see these ads.
Mekks is offline   Reply With Quote
Old 12-02-2012, 07:08 PM   #2
Mekks
Scooby Specialist
 
Member#: 219749
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Upstate NY
Default

Any chance it could be a tension pulley for the timing belt? sounds like its coming from right under the AC comp (ac not hooked up/no belt).
Mekks is offline   Reply With Quote
Old 12-03-2012, 04:01 PM   #3
Mekks
Scooby Specialist
 
Member#: 219749
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Upstate NY
Default

Pulled the timing belt cover off and the lower right idler pulley is bad, it had snapped the bolt off and was still being turned by the belt.

I need a new pulley, bolt and I assume belt also?

Should I be worried about bent valves? seemed to run fine other than the really bad noise.
Mekks is offline   Reply With Quote
Old 12-04-2012, 05:26 PM   #4
sackytar
Scooby Guru
 
Member#: 149262
Join Date: May 2007
Chapter/Region: MWSOC
Location: Grand Rapids MI
Vehicle:
03WR Rally/XTDD/98SJ
PrimerGrey

Default

Wow that sucks.
sackytar is offline   Reply With Quote
Old 12-04-2012, 05:27 PM   #5
sackytar
Scooby Guru
 
Member#: 149262
Join Date: May 2007
Chapter/Region: MWSOC
Location: Grand Rapids MI
Vehicle:
03WR Rally/XTDD/98SJ
PrimerGrey

Default

Replace it and do a compression test.
sackytar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.