Welcome to the North American Subaru Impreza Owners Club Wednesday July 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-18-2012, 11:05 AM   #1
Squeakgp
Scooby Newbie
 
Member#: 300394
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2012 WRX STI
White

Default Weird "whistle" before boost

So, I have been looking for another thread with a description of what I have and I can't find one. So time to post a thread and hope someone with mad search keyword powers doesn't prove me wrong.

So the situation is, I just installed the invidia catless downpipe. I have the factory midpipe and a custom muffler delete. Only other thing I have done is that I removed the intake silencer. Now, during install I did take the IC off but I have rechecked all the hoses. As far as I can tell they are on fine. The real problem with finding this sound is that I really only hear it under load. So revving it with my head under the hood doesn't get the same sound. Also the sound is most prominent pre-boost. Im not sure if the turbo/exhaust drown out the noise while in boost, but it seems to not be there.

Any ideas??
* Registered users of the site do not see these ads.
Squeakgp is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-18-2012, 11:19 AM   #2
findurpath
Scooby Specialist
 
Member#: 277487
Join Date: Mar 2011
Chapter/Region: NWIC
Location: Bozeman, MT and Lakewood, WA
Vehicle:
2006 CGM WRX Limited
6sp, 18G, Phatron tuned

Default

Are you sure it's just not the turbo spooling up? You DID remove the intake silencer...

Did you ask Bub-rub?
findurpath is offline   Reply With Quote
Old 12-18-2012, 11:21 AM   #3
microsnook
Scooby Specialist
 
Member#: 313952
Join Date: Mar 2012
Location: Central FL
Vehicle:
2006 STi
SGM DOM 3xt-r

Default

Its probably normal. I have an aftermarket intake (no silencer) and it makes a whistle before I boost too. I love it! Just more noises.
microsnook is offline   Reply With Quote
Old 12-18-2012, 11:50 AM   #4
Squeakgp
Scooby Newbie
 
Member#: 300394
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2012 WRX STI
White

Default

I'm really not sure if it shouldn't be there. I don't hate the noise, I was just worried it was bad...
Squeakgp is offline   Reply With Quote
Old 12-18-2012, 12:32 PM   #5
eronenris
Scooby Newbie
 
Member#: 262992
Join Date: Nov 2010
Chapter/Region: NWIC
Location: Utah
Vehicle:
2009 WRX - Stage 2
Satin White Pearl

Default

2008+ don't have intake silencers...
eronenris is offline   Reply With Quote
Old 12-18-2012, 12:35 PM   #6
Squeakgp
Scooby Newbie
 
Member#: 300394
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2012 WRX STI
White

Default

Quote:
Originally Posted by eronenris View Post
2008+ don't have intake silencers...
STI's do...
Squeakgp is offline   Reply With Quote
Old 12-18-2012, 01:09 PM   #7
eronenris
Scooby Newbie
 
Member#: 262992
Join Date: Nov 2010
Chapter/Region: NWIC
Location: Utah
Vehicle:
2009 WRX - Stage 2
Satin White Pearl

Default

Quote:
Originally Posted by Squeakgp View Post
STI's do...
oh sorry, i misread thought you had a wrx.
eronenris is offline   Reply With Quote
Old 12-18-2012, 02:25 PM   #8
RoadKillDMD
Scooby Specialist
 
Member#: 284792
Join Date: Jun 2011
Chapter/Region: RMIC
Location: Vanilla Valley, CO
Vehicle:
2011 STI
Blurple

Default

You did an intake 'silencer' delete, and now you're why it's making whistling noises? Sounds like you didn't do much research before diving into something that you know nothing about... Don't do that. Research THREE times BEFORE modding.

Now, to ease your mind a little, the sound is completely normal. Nothing to worry about, as long as all of your boost and vacuum lines are secure and the whistling isn't a boost leak.
RoadKillDMD is offline   Reply With Quote
Old 12-18-2012, 02:56 PM   #9
Squeakgp
Scooby Newbie
 
Member#: 300394
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2012 WRX STI
White

Default

Quote:
Originally Posted by RoadKillDMD View Post
You did an intake 'silencer' delete, and now you're why it's making whistling noises? Sounds like you didn't do much research before diving into something that you know nothing about... Don't do that. Research THREE times BEFORE modding.

Now, to ease your mind a little, the sound is completely normal. Nothing to worry about, as long as all of your boost and vacuum lines are secure and the whistling isn't a boost leak.
The silencer delete was done well before the downpipe. I am very familiar with the normal turbo spool/BPV sound associated with the delete. I like that, hence why I did the mod. This sound was in addition to what I was hearing before. I'm hitting target boost, maybe even have a bit of boost creep, and once again the sound is heard while accelerating but when staying out of boost.

Why is it that 80% of the population on here want to bash first before providing any real help??
Squeakgp is offline   Reply With Quote
Old 12-18-2012, 03:00 PM   #10
99imprezd
Scooby Specialist
 
Member#: 198964
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: south NJ
Vehicle:
2015 WRX
crystal white pearl

Default

Prob normal.. should be loud and whistly.. more power means more noise. lol.
99imprezd is offline   Reply With Quote
Old 12-18-2012, 07:48 PM   #11
n0t an sti
Scooby Newbie
 
Member#: 309488
Join Date: Feb 2012
Chapter/Region: MWSOC
Location: Southern Illinois
Vehicle:
2012 Impreza WRX
Satin White Pearl

Default

My car does the same thing, kind of sounds like a popped balloon rushing noise? I dont have any boost leaks but i do have an invidia catless dp and stock intake
n0t an sti is offline   Reply With Quote
Old 12-19-2012, 09:56 AM   #12
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

at what rpm are you hearing it? for example. ( when im driving in 4th and im at 2k and i punch it i hear this whistle noise about .5-1k rpm's before i feel boost.) if this sounds like your issue. this is completely normal. and you should probably downshift in this situation to prevent overboost.
myblusti is offline   Reply With Quote
Old 12-20-2012, 11:07 AM   #13
Squeakgp
Scooby Newbie
 
Member#: 300394
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2012 WRX STI
White

Default

Quote:
Originally Posted by myblusti View Post
at what rpm are you hearing it? for example. ( when im driving in 4th and im at 2k and i punch it i hear this whistle noise about .5-1k rpm's before i feel boost.) if this sounds like your issue. this is completely normal. and you should probably downshift in this situation to prevent overboost.
It happens in almost any gear during light acceleration, in the 1-3500 rpm range. I don't have a boost gauge, but I do have the AP, and looking at that while accelerating I stay in the negatives when I hear this noise.
Squeakgp is offline   Reply With Quote
Old 12-20-2012, 11:37 AM   #14
99imprezd
Scooby Specialist
 
Member#: 198964
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: south NJ
Vehicle:
2015 WRX
crystal white pearl

Default

In my 04 wrx w/ invidia catless, and perrin catless up-pipe it definitly is way louder than stock.. The sound of rushing air blowing through the dp is crazy. almost sounds like it raining really hard and a little bit of a whistle.. lol. I did have some much louder whistling that turned out to be a bad seal between the Blow off valve and my top mount intercooler whch is common for these to leak, although it didnt effect my performance at all was annoying as hell.. If you think its louder than it should be and have messed with any of the hoses to the blow off or turbo inlet, double check for leaks.. even a small one will make one hell of a ruckus..
99imprezd is offline   Reply With Quote
Old 12-20-2012, 12:14 PM   #15
Squeakgp
Scooby Newbie
 
Member#: 300394
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2012 WRX STI
White

Default

I was starting to wonder about that piece as well. Was your leak enough to feel with your hand or did you have to do something else to find it?
Squeakgp is offline   Reply With Quote
Old 12-20-2012, 12:34 PM   #16
99imprezd
Scooby Specialist
 
Member#: 198964
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: south NJ
Vehicle:
2015 WRX
crystal white pearl

Default

Quote:
Originally Posted by Squeakgp View Post
I was starting to wonder about that piece as well. Was your leak enough to feel with your hand or did you have to do something else to find it?
heres a vid to how I found my leak at my BOV.. you could do the same thing without disassembly prob for individual hoses etc.. was only using about 20psi in my compressor..

http://s829.beta.photobucket.com/use...rleak.mp4.html
99imprezd is offline   Reply With Quote
Old 12-20-2012, 03:30 PM   #17
WRXSteye20008
Scooby Specialist
 
Member#: 175565
Join Date: Mar 2008
Chapter/Region: MAIC
Location: Lancaster, PA
Vehicle:
2014 Sport Premium
Past: 351awhp Sti

Default

Quote:
Originally Posted by findurpath View Post
Are you sure it's just not the turbo spooling up? You DID remove the intake silencer...

Did you ask Bub-rub?
Fantastic reference, I knew exactly what you meant when you said it. For those who don't.


OP take a video of the sound it could be a million sounds and from what you are describing sounds the the silencer delete however we have no idea. Make a video and post it so we can better help you, otherwise it could be anything. My bet it is the turbo spool you are hearing the the silencer not there as it does make it a bit louder. Everyone on here who has the silencer delete, took it out, we know what it sounds like.


WRXSteye20008 is offline   Reply With Quote
Old 12-20-2012, 04:21 PM   #18
Squeakgp
Scooby Newbie
 
Member#: 300394
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2012 WRX STI
White

Default

Oh lol, I didn't catch that reference. I have however seen that awesome video before. I will try and take a video but I have a feeling the microphone will mostly pick up my exhaust, it's kinda loud.... We will see
Squeakgp is offline   Reply With Quote
Old 12-23-2012, 09:41 PM   #19
Bryan18
Scooby Newbie
 
Member#: 141238
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Somewhere, MA
Vehicle:
2006 STi
Crystal Gray Metallic

Default

Sounds like a boost leak...i had the same sound after a bov install. The gasket on the bov had a slight tear in it
Bryan18 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.