Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-08-2012, 08:13 PM   #1
ierichuljev
Scooby Newbie
 
Member#: 330442
Join Date: Aug 2012
Chapter/Region: TXIC
Location: Spring, TEXAS
Vehicle:
2002 WRX
Midnight Black Pearl

Default Idler pulley ?

I have this annoying noise coming from my engine starts to whine at about 1800k rpm ill post a Video when I have time but I believe it is the idle pulley has anyone had this problem ! It's a 2002 Wrx and is it easy to replace ? I looked for the part online and can't seem to find it
* Registered users of the site do not see these ads.
ierichuljev is offline   Reply With Quote
Old 12-09-2012, 07:02 PM   #2
Mental
Scooby Newbie
 
Member#: 321773
Join Date: May 2012
Location: Exton, PA
Vehicle:
2005 WRX
Aspen White

Default

Could be the idler pulley. Go to any autozone type place and they should be able to look it up under the AC section of their parts catalog for your car. Costs around $30.

To install, remove the belt cover (1 bolt 1 nut) and the entire idler assembly (2 bolts at the top of it; I loosened the tension first though I'm not sure that that is necessary except to re install) Take off the pulley, knock out the center section to put in your new pulley, and re install.
Mental is offline   Reply With Quote
Old 12-09-2012, 08:40 PM   #3
shano
Scooby Newbie
 
Member#: 223839
Join Date: Sep 2009
Chapter/Region: E. Canada
Location: Sudbury, Ontario
Vehicle:
2004 WRX
Java black

Default

Yup just did mine, the pulley was metal and better quality than the oem one. Annoying sound gone!
shano is offline   Reply With Quote
Old 12-10-2012, 05:09 PM   #4
multiplexer
Scooby Newbie
 
Member#: 39518
Join Date: Jul 2003
Location: NorCal
Default

I've got a similar noise on mine. Every morning, about a minute after I start her up, I hear this low frequency whine. It goes away as it warms up. I went ahead and replaced the idler pulley since it was a relatively cheap part but it wasn't the cause in my case.

Removing the Alt/PS belt eliminates the noise. I noticed there's a little play in the PS pulley and none in Alt pulley. Is this an indication of PS pump going out? Any way to service it? I don't see any leaks.

I tried to use a screwdriver as a stethoscope but both Alt and PS are noisy. I couldn't tell if one sounds worse than other. Both pulleys spin by hand without noise, but the PS pullet is considerably harder to keep spinning (it stops almost instantly).
multiplexer is offline   Reply With Quote
Old 12-10-2012, 05:12 PM   #5
art@grimmspeed
NASIOC Vendor
 
Member#: 301037
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2004 Forester XT
Aspen White

Default

Yeah this is one of those limited times that Advance Auto Parts has a better part than oem.
art@grimmspeed is offline   Reply With Quote
Old 12-10-2012, 05:13 PM   #6
Prlbluwrx
Scooby Newbie
 
Member#: 307853
Join Date: Jan 2012
Chapter/Region: BAIC
Location: Concord
Vehicle:
2005 WRX
Blue

Default

Very easy to replace most parts store will stock it. Mine went out at about 115k. it started making a grinding noise. It took me about 30 min to swap.
Prlbluwrx is offline   Reply With Quote
Old 12-12-2012, 02:18 AM   #7
ierichuljev
Scooby Newbie
 
Member#: 330442
Join Date: Aug 2012
Chapter/Region: TXIC
Location: Spring, TEXAS
Vehicle:
2002 WRX
Midnight Black Pearl

Default

Are there any write ups for this ? Or should I just taw it to Subaru ? I know Incan do it I just need the guidance lol.
ierichuljev is offline   Reply With Quote
Old 12-16-2012, 04:19 PM   #8
ierichuljev
Scooby Newbie
 
Member#: 330442
Join Date: Aug 2012
Chapter/Region: TXIC
Location: Spring, TEXAS
Vehicle:
2002 WRX
Midnight Black Pearl

Default

I fixed it today was the easiest fix ever I didn't even need directions . It's only 3 bolts and no more annoying whine ! Thanks everyone for the help !
ierichuljev is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.