Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-28-2012, 04:05 PM   #1
timmyotool
Scooby Newbie
 
Member#: 341169
Join Date: Dec 2012
Location: new ipswich nh
Vehicle:
02 wrx
blue

Default new guy new clutch issue

installed a new clutch. since i have never done one before and im new to forums. im posting this here.

02 wrx hybrid motor. emc flash of some kind. bought an f1 stage 2 with lightened fly wheel. all was well with the install. 1000ft down the road on the test run release bearing pulled out. so tore the trans out and reassembled. still ok been driving it a few days now.

question is how long till the burnt clutch smell stops or is it broken?
* Registered users of the site do not see these ads.
timmyotool is offline   Reply With Quote
Old 12-28-2012, 06:10 PM   #2
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

It seems that most people have the smell/ stutter linger around for about 500 miles. I did a clutch about 3 weeks ago and it took 2 weeks of city driving for it to seem normal.

Mike
GrimmSpeed is offline   Reply With Quote
Old 12-29-2012, 04:51 AM   #3
timmyotool
Scooby Newbie
 
Member#: 341169
Join Date: Dec 2012
Location: new ipswich nh
Vehicle:
02 wrx
blue

Default

Quote:
Originally Posted by GrimmSpeed View Post
It seems that most people have the smell/ stutter linger around for about 500 miles. I did a clutch about 3 weeks ago and it took 2 weeks of city driving for it to seem normal.

Mike
ok thanks thats the reassurance i was looking for
timmyotool is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.