Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-22-2012, 07:20 PM   #1
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default weird tickling/clacking sound :(

so today I happens to go down a road with a pretty nasty surface, so I went really slow 10 and under and I scraped in a few spots... now I have this disguisting banging/clacking/ticking sound when I drive sounded like something was dragging but I went under and nothing was hitting the ground. it only seems to happen when I accelerate then let go, and it happened once when I parked to get out and look under again. from inside the car it sounds like its coming from ether the right front or behind the center console or right around that area. any ideas? hoping I didn't break any part of the tranny...
* Registered users of the site do not see these ads.
spazsubaru is offline   Reply With Quote
Old 12-22-2012, 08:15 PM   #2
Counterfit
Scooby Guru
 
Member#: 124254
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2006 06 SGM Slowbaru
"The Scoobinator"

Default

Check the boots on the inner joint of the front axle. It may have gotten torn and allowed junk inside.
Counterfit is offline   Reply With Quote
Old 12-22-2012, 08:21 PM   #3
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

Quote:
Originally Posted by Counterfit View Post
Check the boots on the inner joint of the front axle. It may have gotten torn and allowed junk inside.
will look tomorrow when its not so windy if possible.
spazsubaru is offline   Reply With Quote
Old 12-24-2012, 01:05 AM   #4
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

bent pipe hitting frame was it so far...
spazsubaru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.