Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-24-2012, 03:01 PM   #1
Twrx77
Scooby Newbie
 
Member#: 320953
Join Date: May 2012
Location: Ohio
Vehicle:
2006 impreza wrx tr
red

Default tomie el expreme headers 06 wrx

When I went to buy these headers alot of websites were saying will work with 06 wrx.others just for 08-12 only wrxs. So 711 dollars later there here and I went to put them only to find out that it keeps hitting my oil filter housing and refuses to go on. Looking on u tube seeing 07 wrx with the same headers that will not work on my 06 im thinking what did I do wrong. I like el headers and just wondering if anybody can help. P.s. I know the older wrxs had a problem with oil pan but I have the 2. 5 oil pan so no problem there.
* Registered users of the site do not see these ads.
Twrx77 is offline   Reply With Quote
Old 12-24-2012, 10:15 PM   #2
424wrx
Scooby Guru
 
Member#: 171948
Join Date: Feb 2008
Chapter/Region: Tri-State
Location: new york
Vehicle:
2008 vf52wrx12.6@108
11 forester,14 legacy

Default

i have them on my 08 wrx. no issues. i think you need an sti oil pan to run them on your car.
424wrx is offline   Reply With Quote
Old 12-24-2012, 11:04 PM   #3
mod maniac
Scooby Specialist
 
Member#: 300551
Join Date: Nov 2011
Chapter/Region: SCIC
Location: mariposa ca.
Vehicle:
2&4 fxt & fxt sti
Fullers Garage

Default

I have them on my 02 no problem. I had to change my oil pan though.
mod maniac is offline   Reply With Quote
Old 12-24-2012, 11:24 PM   #4
Airboy
Scooby Specialist
 
Member#: 72829
Join Date: Oct 2004
Chapter/Region: W. Canada
Location: Calgary, Canada
Vehicle:
2006 WRX
EFR6758

Default

The heat exchanger coupler by the oil filter is the part that needs to be changed. The affected parts are highlighted in the pic at the Perrin site:
http://www.perrinperformance.com/sub...r-equal-length

Airboy is offline   Reply With Quote
Old 12-25-2012, 02:03 AM   #5
Twrx77
Scooby Newbie
 
Member#: 320953
Join Date: May 2012
Location: Ohio
Vehicle:
2006 impreza wrx tr
red

Default

Heat exchange is it easy to buy or fix
Twrx77 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.