Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-24-2012, 02:34 PM   #1
Sickashelltom
Scooby Newbie
 
Member#: 330977
Join Date: Sep 2012
Location: Brick,NJ
Vehicle:
2007 $Ti
Instagram: sickashelltom

Default Ticking Interior Noise

So i i have a 07 Sti, and there is a faint but ANNOYING noise, you can here it clearly when the windows are up in the interior, sounds like its coming from the drivers side,and the ticking gets faster as i go faster,and goes away when the car is in neutral, there are no vacuum leaks as we have tested it,and there is no loss of power,or any issues,its just a annoying lil noise, it almost sounds like a leaf stuck in the air vent...If anyone else know anything about this,please get back to me thanks..
* Registered users of the site do not see these ads.
Sickashelltom is offline   Reply With Quote
Old 12-24-2012, 04:50 PM   #2
Mr Wrex
Scooby Specialist
 
Member#: 332887
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Orange County, NY
Vehicle:
2012 WRX stage 2+
DGM (sedan)

Default

A video would be nice
Mr Wrex is offline   Reply With Quote
Old 12-24-2012, 06:43 PM   #3
Sickashelltom
Scooby Newbie
 
Member#: 330977
Join Date: Sep 2012
Location: Brick,NJ
Vehicle:
2007 $Ti
Instagram: sickashelltom

Default

Yeah ill have to take a small video clip,thats a good idea
Sickashelltom is offline   Reply With Quote
Old 04-19-2013, 11:53 AM   #4
CameronWRX
Scooby Newbie
 
Member#: 345469
Join Date: Jan 2013
Chapter/Region: Tri-State
Vehicle:
2007 WRX TR
SWP

Default

dead thread revived! you ever figure this problem out?? I have the same EXACT symptoms on my 07 wrx
CameronWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.