Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-31-2012, 12:22 PM   #1
USLiberty
Scooby Newbie
 
Member#: 294466
Join Date: Sep 2011
Chapter/Region: SWIC
Location: prescott az
Vehicle:
1993 Legacy SS
white

Default

I have a link plus standalone ems, I use it in 4-multicoil spark with 2-dual channel link ignitors. I'm using the factory subaru 2bolt- coilpacks(COP)that came with the phase 1 ej20g, I've been burning coilpacks randomly, sometimes its 6 months before I lose a cylinder other times its weeks. Did some calling around and apparently the ecu's dwell time is too long for the factory coilpacks and they overheat and fail. I found the AEM "dumb" coilpacks for about 240$ for 4, they look like they could handle a lot more heat and throw a much brighter spark. I don't want to switch to a wasted spark ignition as i have tried without any success. Anyone have any experience with the aem coil packs?
* Registered users of the site do not see these ads.

Last edited by USLiberty; 12-31-2012 at 01:06 PM.
USLiberty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.