Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-31-2012, 03:07 PM   #1
camlupi
Scooby Newbie
 
Member#: 285365
Join Date: Jun 2011
Chapter/Region: NESIC
Vehicle:
2005 Wrx sti
blue

Default help!05 sti misfiring and other issues

Alright guys im sure this will come to no surprise but a chance to get an sti came up and i took it, and there are issues(im hoping not too big of ones). first off the mod list from what i can see --- aftermarket tmic, (not sure what it is ill enclose pics), hks bov, looks like samco turbo inlet, cold air intake( not sure on the name), greddy radiator, greddy full exhaust cept for downpipe which is stock and the turbo does look different from what ive seen, it says td05 on it? car was fine till the end of the drive home and i punched it a bit, the car sputtered and lost power(right around 4k) cel blinked for a bit then went away. I tried it again and it did the same but the cel stayed on. I scanned the code and it says misfire cyl 1.( random note: i tried a friends ap1 access port and it does have a tune on it but it being an ap1 couldn't unmarry the ecu.)thoughts on what i should do from here? I bought plugs but i have a feeling its something more serious. Next up is the driver side head started making a bit more noise than before, kind of louder than the normal suby tick, from what it looks like the head and all gaskets are brand new , thoughts? serious issue? should i not drive it?
also seller feedback is not an option so im slowly finding mod after mod. ( on a side note it has brembos but they are black not gold but do say brembo, stock? earlier year? thanks guys
* Registered users of the site do not see these ads.
camlupi is offline   Reply With Quote
Old 12-31-2012, 10:53 PM   #2
Andrewxxcarlson
Scooby Specialist
 
Member#: 316415
Join Date: Apr 2012
Location: Elk Grove, CA
Vehicle:
2006 WRX
WRB

Default

I wouldn't drive that if you want your money's worth, td05 is not stock turbo on the sti's, they come with vf series turbos. I couldn't see your pics. If I were you I'd highly suggest a tune. And see what your tuner has to say. Second option, which I would probably do first is put it all back to stock with a stock tune. Then compression test.
Andrewxxcarlson is offline   Reply With Quote
Old 01-01-2013, 08:16 AM   #3
camlupi
Scooby Newbie
 
Member#: 285365
Join Date: Jun 2011
Chapter/Region: NESIC
Vehicle:
2005 Wrx sti
blue

Default

Quote:
Originally Posted by Andrewxxcarlson View Post
I wouldn't drive that if you want your money's worth, td05 is not stock turbo on the sti's, they come with vf series turbos. I couldn't see your pics. If I were you I'd highly suggest a tune. And see what your tuner has to say. Second option, which I would probably do first is put it all back to stock with a stock tune. Then compression test.
Rough idea on how much it is to go back to stock?
camlupi is offline   Reply With Quote
Old 01-01-2013, 02:22 PM   #4
k mier
Scooby Specialist
 
Member#: 98000
Join Date: Oct 2005
Location: MO
Vehicle:
05 sti e85@420hp

Default

'05 sti came with the vf39. When you change the plugs take a close look at the old ones, they may give you a clue what's wrong.

Not sure what you're saying about it being tuned, your friend's car had a tune on it, or your car has a tune, or.....

...anyhow, not sure I'd ever buy a modded suby without a serious and thorough inspection, just too many ways to make spare parts out of one.
k mier is offline   Reply With Quote
Old 01-01-2013, 02:44 PM   #5
camlupi
Scooby Newbie
 
Member#: 285365
Join Date: Jun 2011
Chapter/Region: NESIC
Vehicle:
2005 Wrx sti
blue

Default

I agree I made a mistake I thought I inspected it enough now I need to clean things up , my car had a tune on it because I plugged a friends ap1 Cobb tuner into it and it said " already had Cobb tune "
camlupi is offline   Reply With Quote
Old 01-01-2013, 03:22 PM   #6
k mier
Scooby Specialist
 
Member#: 98000
Join Date: Oct 2005
Location: MO
Vehicle:
05 sti e85@420hp

Default

Now I guess it's time to play detective trying to figure out what mods it had, what might have been removed/changed before you bought it, and what has happened to it since you've driven it. Since you didn't see a name on the top mount I'll guess the aftermarket is an e-bay, shouldn't change much in the way of tunage from the stock one. BOV prolly no damage there. Don't know why they would have an aftermarket cai on a stock turbo when the oem flows plenty. Exhaust but no downpipe, the downpipe's where most of the power is gained. Don't see td05 anywhere on the turbo, to the right of and just below where it says IHIturbo on the compressor side it will have vf39 along with some other info stenciled into it.

Time to do some investigating. Do the bolts on the downpipe, upipe, look new or clean? If so sure sign the turbo has been swapped recently.
k mier is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.