Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Bay Area Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Bay Area Impreza Club Forum -- BAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-02-2013, 10:17 PM   #1
geronimo81
Scooby Specialist
 
Member#: 154586
Join Date: Jul 2007
Chapter/Region: BAIC
Location: San Ramon
Vehicle:
1996 Turbo Outback
9psi on 91 No EM

Default Need a fuel pump in San Ramon

My 1996 Outback needs a fuel pump. I got one out of an '07 wrx and it was bad as well.

I am 99% sure it is the fuel pump since it won't come on even though I have confirmed there is power at the pump.

Anybody got one?
* Registered users of the site do not see these ads.
geronimo81 is offline   Reply With Quote
Old 01-04-2013, 11:45 AM   #2
Strider327
Scooby Specialist
 
Member#: 131280
Join Date: Nov 2006
Chapter/Region: BAIC
Location: Northern California Hayward
Vehicle:
2004 Impreza WRX
WRB

Default

I have one.
Strider327 is offline   Reply With Quote
Old 01-05-2013, 12:18 AM   #3
jlien619
Scooby Newbie
 
Member#: 296522
Join Date: Oct 2011
Chapter/Region: BAIC
Location: Orinda/Rocklin CA
Vehicle:
2008 WRX
Dark Gray

Default

i have a few
jlien619 is offline   Reply With Quote
Old 01-05-2013, 12:48 PM   #4
geronimo81
Scooby Specialist
 
Member#: 154586
Join Date: Jul 2007
Chapter/Region: BAIC
Location: San Ramon
Vehicle:
1996 Turbo Outback
9psi on 91 No EM

Default

Thanks guys. I got a whole assembly and found out that the connector in my assembly went bad. So now I have 3 working fuel pumps.

I ended up putting the '07 wrx pump in.
geronimo81 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.