Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
New England Subaru Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > New England Impreza Club Forum -- NESIC > NESIC Private Classifieds

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-15-2013, 02:42 PM   #1
RedImpreza07
Scooby Newbie
Member Sales Rating: (9)
 
Member#: 130600
Join Date: Oct 2006
Chapter/Region: NESIC
Location: Sanford, Me.
Vehicle:
2004 WRX
Silver

Default 06/07 WRX cluster 57.8k miles

Up for sale is a 06/07 WRX cluster. has approx 57800 miles + - 100 miles. Great shape no scratches. Everything works exept if you do not have auto matic climate control the Outside temp guage will read --- F. This is what I've been able to find out. Two of the illumination bulbs are bad. I installed the cluster to confirm these issues. swapped in two good bulbs and everthing works, all gauges work. reason for selling I'm monitoring head gasket oil seeping and need to keep the original cluster in. $50. will help install if needed in my garage. No key programming needed. Plug and play. The image in the picture is from the day I installed it. drove with it for a little more than a week before having to install the 2.5i cluster



* Registered users of the site do not see these ads.
RedImpreza07 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.