Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-15-2013, 08:12 PM   #1
bradze
Scooby Specialist
 
Member#: 103208
Join Date: Dec 2005
Chapter/Region: NWIC
Location: Yelm, Wa
Vehicle:
2011 Outback
Azurite Blue

Default what all do i need to install a pioneer avic x910bt?

this radio was installed in my wife's '08 OBS. last year when we traded for a '12 impreza sport limited i had the dealer take the radio out. what dash kit and wiring harness will i need? thanks. or would the dash kit that was in her last impreza fit the new impreza?
* Registered users of the site do not see these ads.
bradze is offline   Reply With Quote
Old 01-29-2013, 10:37 PM   #2
bradze
Scooby Specialist
 
Member#: 103208
Join Date: Dec 2005
Chapter/Region: NWIC
Location: Yelm, Wa
Vehicle:
2011 Outback
Azurite Blue

Default

anyone know what kind of harness i would need for a stereo?
bradze is offline   Reply With Quote
Old 01-29-2013, 11:08 PM   #3
blzr25x
Scooby Newbie
 
Member#: 337689
Join Date: Nov 2012
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 Impreza Premium
DGM Sedan

Default

blzr25x is offline   Reply With Quote
Old 01-30-2013, 07:40 AM   #4
goregasm
*** Banned ***
 
Member#: 331656
Join Date: Sep 2012
Vehicle:
2012 2.0i
Marine Blue Pearl

Default

You're not going to get help posting in the wrong forum. Go to audio/security.
goregasm is offline   Reply With Quote
Old 01-30-2013, 09:49 PM   #5
bradze
Scooby Specialist
 
Member#: 103208
Join Date: Dec 2005
Chapter/Region: NWIC
Location: Yelm, Wa
Vehicle:
2011 Outback
Azurite Blue

Default

thanks blzr25x
bradze is offline   Reply With Quote
Old 01-12-2014, 09:00 PM   #6
bradze
Scooby Specialist
 
Member#: 103208
Join Date: Dec 2005
Chapter/Region: NWIC
Location: Yelm, Wa
Vehicle:
2011 Outback
Azurite Blue

Default

ok so this just keeps getting put off and put off. will the steering wheel controls be the same? i had an installer put it in the last car but they charged almost 3x what they estimated. i was so pissed when i paid $500 for that radio, then over $500 for the install.
bradze is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.