Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-16-2013, 12:54 PM   #1
ivanbih
Scooby Specialist
 
Member#: 227738
Join Date: Oct 2009
Location: Texas
Vehicle:
02 WRX
sittin' tall

Default Squeaky clutch pedal

Hey guys i have a squeaky clutch pedal on my 02 WRX,it only makes a very short squeal when i depress it completely, i tried lubing up all of the moving parts that i could see under my dash, anyone know what I can do to stop this?

Here is a video so you can hear it:

* Registered users of the site do not see these ads.
ivanbih is offline   Reply With Quote
Old 01-16-2013, 06:55 PM   #2
allroy81
Scooby Newbie
 
Member#: 62260
Join Date: May 2004
Chapter/Region: Tri-State
Location: brick, nj
Vehicle:
2004 sti
2013 forester

Default

Are you sure you greased everything? I had a similar problem, I missed a spot and my buddy went under there and found something I missed, no more squeaking.
allroy81 is offline   Reply With Quote
Old 01-16-2013, 10:41 PM   #3
ivanbih
Scooby Specialist
 
Member#: 227738
Join Date: Oct 2009
Location: Texas
Vehicle:
02 WRX
sittin' tall

Default

I ended up spraying WD-40 on basically everything down there, and it still persists.. The squeak is really starting to annoy me.
ivanbih is offline   Reply With Quote
Old 01-16-2013, 10:54 PM   #4
CraftyCraft
Scooby Newbie
 
Member#: 340451
Join Date: Dec 2012
Chapter/Region: SWIC
Location: Tucson
Vehicle:
2004 "Franken-STi"
Aspen White

Default

I am a big fan of white lithium grease. Maybe you could try some of that?
CraftyCraft is offline   Reply With Quote
Old 01-17-2013, 08:43 AM   #5
allroy81
Scooby Newbie
 
Member#: 62260
Join Date: May 2004
Chapter/Region: Tri-State
Location: brick, nj
Vehicle:
2004 sti
2013 forester

Default

I used white lithium grease to fix mine, it hasn't squeaked in a few years now
allroy81 is offline   Reply With Quote
Old 01-19-2013, 01:06 PM   #6
ivanbih
Scooby Specialist
 
Member#: 227738
Join Date: Oct 2009
Location: Texas
Vehicle:
02 WRX
sittin' tall

Default

I just used like half a can of white lithium spraying EVERYthing down there, still squeaking... Is there anyway that one of those springs is just bad? I dont even know how I could go about replacing one of them..
ivanbih is offline   Reply With Quote
Old 01-19-2013, 01:42 PM   #7
ivanbih
Scooby Specialist
 
Member#: 227738
Join Date: Oct 2009
Location: Texas
Vehicle:
02 WRX
sittin' tall

Default

I think the culprit is this spring right here, I tried spraying it all over with WD-40 & white lithium grease and it is still the same. Any way I could easily take this thing off and inspect it??

ivanbih is offline   Reply With Quote
Old 01-19-2013, 01:53 PM   #8
allroy81
Scooby Newbie
 
Member#: 62260
Join Date: May 2004
Chapter/Region: Tri-State
Location: brick, nj
Vehicle:
2004 sti
2013 forester

Default

My problem was actually above the gas pedal, look under there and press the clutch a little bitt with your hand, and you'll see part of the assembly moving, there's a joint there, try the white lithium grease in there.
allroy81 is offline   Reply With Quote
Old 01-19-2013, 03:40 PM   #9
ivanbih
Scooby Specialist
 
Member#: 227738
Join Date: Oct 2009
Location: Texas
Vehicle:
02 WRX
sittin' tall

Default

Quote:
Originally Posted by allroy81 View Post
My problem was actually above the gas pedal, look under there and press the clutch a little bitt with your hand, and you'll see part of the assembly moving, there's a joint there, try the white lithium grease in there.
Yea i also tried slathering it on there with no luck

You can only hear it when i press in my clutch fast too, if I do it slow its tolerable.
ivanbih is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.