Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-21-2013, 01:03 AM   #1
Warlo3k
Scooby Newbie
 
Member#: 325957
Join Date: Jul 2012
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
2012 WRX Sedan
Black

Default ecU shuts off underwot

I am pretty sure i have a grounding issue. the ecu cuts out under wot and sometimes randomly while driving. The dealer says my ecu is randomly shutting off. can anyone tell me on the 2012 wrx where I can look to find any grounding issues?
* Registered users of the site do not see these ads.
Warlo3k is offline   Reply With Quote
Old 01-21-2013, 01:29 AM   #2
the suicidal eggroll
NASIOC Supporter
 
Member#: 51961
Join Date: Jan 2004
Chapter/Region: RMIC
Location: Broomfield, CO
Vehicle:
2005 STi
2012 WRX

Default

The dealer told you your ecu is randomly shutting off and they did nothing to fix the problem? Why not?
the suicidal eggroll is offline   Reply With Quote
Old 01-21-2013, 02:42 AM   #3
Warlo3k
Scooby Newbie
 
Member#: 325957
Join Date: Jul 2012
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
2012 WRX Sedan
Black

Default

Yeah the car is modded and they said it is a failed ecu and will be about $1000 dollars to fix.

I think I figured it out though.

I made a ground wire out of some good gauge wire and some wire ends I had laying around. I attached it from the ground point that the factory uses (the one on the back of the drivers side fuel rail shield) to a chassis ground. After 10 pulls, not a single hesitation! I'm going to run it tomorrow as well for a good trip to verify it is indeed fixed.
Warlo3k is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.