Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-23-2013, 04:21 PM   #1
Wavemandan
Scooby Newbie
 
Member#: 341351
Join Date: Dec 2012
Chapter/Region: South East
Location: Stuart, fl
Vehicle:
2007 Sti
Pearl White

Default Aux audio button non-existent

I have a 2007 Sti sedan and I have an aux port but I can't get the oem head unit to turn to it.
* Registered users of the site do not see these ads.
Wavemandan is offline   Reply With Quote
Old 01-23-2013, 05:15 PM   #2
Wavemandan
Scooby Newbie
 
Member#: 341351
Join Date: Dec 2012
Chapter/Region: South East
Location: Stuart, fl
Vehicle:
2007 Sti
Pearl White

Default

This is really irritating. Someone's gotta know this.
Wavemandan is offline   Reply With Quote
Old 01-23-2013, 10:46 PM   #3
chris07sti
Scooby Newbie
 
Member#: 177312
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Manhattan, KS
Vehicle:
2005 STI
Aspen white

Default

you should just be able to push the AUX button. From your title, do you not have that button? if not you probably have a older head unit.



OR

chris07sti is offline   Reply With Quote
Old 01-24-2013, 08:15 PM   #4
Wavemandan
Scooby Newbie
 
Member#: 341351
Join Date: Dec 2012
Chapter/Region: South East
Location: Stuart, fl
Vehicle:
2007 Sti
Pearl White

Default

I have an older head unit. So I have to get a new one?
Wavemandan is offline   Reply With Quote
Old 01-26-2013, 12:30 AM   #5
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by Wavemandan View Post
I have a 2007 Sti sedan and I have an aux port but I can't get the oem head unit to turn to it.
Most likely explanations:

A) Your STi originally had a different OEM HU (with aux capability --that feature was added in 2007 Impreza models), but the previous owner removed it for some reason and replaced it with an older model.

B) Yours is the one that originally came with your car, and someone used an aftermarket accessory to add aux. Could be an FM modulator (where you must tune to a certain FM station, and possibly need to flip a hidden switch to activate/deactivate), or a hack soldered inside the HU. Pull out your HU and see where the aux cable goes.

Is it a factory aux jack (where the ashtray would be)?

What is the model number printed on the front of your HU?
SVXdc is offline   Reply With Quote
Old 01-27-2013, 01:56 AM   #6
SlowCB7
Scooby Newbie
 
Member#: 343576
Join Date: Jan 2013
Vehicle:
2005 Saab 9-2x Aero

Default

It also could be the Jazzy Engineering factory add-in aux input, that's what I have. If that's what it is you'll need a silent CD and it should just play over the CD channel
SlowCB7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.