Welcome to the North American Subaru Impreza Owners Club Wednesday July 9, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-24-2013, 11:11 AM   #1
stikilla
Scooby Newbie
 
Member#: 117796
Join Date: Jun 2006
Chapter/Region: MAIC
Location: nova
Vehicle:
2006 Corvette
white

Default USB Port trouble

Good morning all,

I drive a 2011 sti hatchback for reference. I recently purchased an iphone 5 and when I plug the charger into the USB port inside the armrest it does not seem to be charging or having any interface whatsoever. I was wondering if anyone else has run across this problem. Could very well be user error on my part. Thanks for the info.
* Registered users of the site do not see these ads.
stikilla is offline   Reply With Quote
Old 01-24-2013, 11:19 AM   #2
Schikane
Scooby Newbie
 
Member#: 337700
Join Date: Nov 2012
Location: Minnesota
Vehicle:
2013 WRX
Ice Silver Metallic

Default

Quote:
Originally Posted by stikilla View Post
Good morning all,

I drive a 2011 sti hatchback for reference. I recently purchased an iphone 5 and when I plug the charger into the USB port inside the armrest it does not seem to be charging or having any interface whatsoever. I was wondering if anyone else has run across this problem. Could very well be user error on my part. Thanks for the info.
You have to switch the radio over to usb to be able to draw power from the hub. Just get a y-adapter and plug it into your cigarette lighter.
Schikane is offline   Reply With Quote
Old 01-24-2013, 11:21 AM   #3
Napalm3nema
Scooby Specialist
 
Member#: 263954
Join Date: Nov 2010
Location: Houston, TX
Vehicle:
2014 EVO Yes, EVO
Wicked White

Default

I'd wager that it would charge an iPhone 4/4s, and just can't charge the 5. On my 08, the stock radio wouldn't charge 'newer' nano's that I use for music, but did work with the generation 1 Nano. It would play the newer ones, just not charge them... I'd wager that's what is going on with you.

That all being said, the stock radio is horrible, and the 'weak link' in the car's audio. If you get a replacement headunit, newer, it should support your iPhone 5. Just be sure to get a signal to noise ratio of > 92 or the new radio will sound as crappy as the stock one.

Hope this helps!
Napalm3nema is offline   Reply With Quote
Old 01-24-2013, 11:21 AM   #4
stikilla
Scooby Newbie
 
Member#: 117796
Join Date: Jun 2006
Chapter/Region: MAIC
Location: nova
Vehicle:
2006 Corvette
white

Default

User error as expected. Haha. Thank you for the response. I figured I'd just get a usb port that plugs into the lighter.
stikilla is offline   Reply With Quote
Old 01-24-2013, 11:22 AM   #5
04shizzel
Scooby Newbie
 
Member#: 186206
Join Date: Aug 2008
Chapter/Region: NESIC
Location: branford, ct
Vehicle:
15 wrx
Ice Silver Metalic

Default

Have you put the radio on the usb setting, and turned off bluetooth?
If your bluetooth is active the usb will not work. hopefully yhis will be helpful.
04shizzel is offline   Reply With Quote
Old 01-24-2013, 11:34 AM   #6
LUMBERZACK
Scooby Specialist
 
Member#: 340009
Join Date: Dec 2012
Chapter/Region: SWIC
Location: Arizona
Vehicle:
2007 STi
48W

Default

I don't know what I would rather have, the AUX port that my 07 came with or a USB in it's place. Hmmm.
LUMBERZACK is online now   Reply With Quote
Old 01-24-2013, 11:35 AM   #7
Napalm3nema
Scooby Specialist
 
Member#: 263954
Join Date: Nov 2010
Location: Houston, TX
Vehicle:
2014 EVO Yes, EVO
Wicked White

Default

Quote:
Originally Posted by 04shizzel View Post
Have you put the radio on the usb setting, and turned off bluetooth?
If your bluetooth is active the usb will not work. hopefully yhis will be helpful.
In my case it wouldn't charge no matter what. Could be different with his 11 however. <shrug>

Academic now for me. I tossed the stock headunit and the aftermarket charges, and the car now has a decent sounding stereo. I'd say an 80% improvement over stock. (that's with stock everything, and just replacing the head unit)

P.S. If this IS the fix for him, doesn't that mean he can't listen to the radio and charge his phone at the same time? That seems rather fail-like to me?
Napalm3nema is offline   Reply With Quote
Old 01-24-2013, 11:40 AM   #8
stikilla
Scooby Newbie
 
Member#: 117796
Join Date: Jun 2006
Chapter/Region: MAIC
Location: nova
Vehicle:
2006 Corvette
white

Default

yeah that is a crappy situation. but in a pinch if i needed the juice then whatever. My hope is that it will interface and i can just listen to a playlist or 2 while it charges. ill be figuring it out after work today.
stikilla is offline   Reply With Quote
Old 01-24-2013, 11:54 AM   #9
Loyale93
Scooby Guru
 
Member#: 91347
Join Date: Jul 2005
Chapter/Region: NESIC
Location: Moscow, Russia
Vehicle:
'13 XV Crosstrek,
1050 Triumph Speed Triple

Default

Quote:
Originally Posted by Schikane View Post
You have to switch the radio over to usb to be able to draw power from the hub. Just get a y-adapter and plug it into your cigarette lighter.
This. I had the same problem on '13 Crosstrek XV. Brand new car and USB wouldn't work. I was pissed off.

But, yes. If you flip it to the USB mode on the radio, the USB port will have power and then you can go back to radio, bluetooth, whatever.

Quote:
P.S. If this IS the fix for him, doesn't that mean he can't listen to the radio and charge his phone at the same time? That seems rather fail-like to me?
No, you just need to flip it to USB once, then the port is turned on. After that, you can go back to whatever else.
Loyale93 is offline   Reply With Quote
Old 01-24-2013, 05:39 PM   #10
WRX boarder
Scooby Newbie
 
Member#: 328399
Join Date: Aug 2012
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2012 WRX Limited
OBP

Default

My experience has been this only happens with the iphones. My usb will charge all my other accessories without going into the usb mode.
WRX boarder is offline   Reply With Quote
Old 01-24-2013, 08:29 PM   #11
Schikane
Scooby Newbie
 
Member#: 337700
Join Date: Nov 2012
Location: Minnesota
Vehicle:
2013 WRX
Ice Silver Metallic

Default

Quote:
Originally Posted by Napalm3nema View Post
I'd wager that it would charge an iPhone 4/4s, and just can't charge the 5. On my 08, the stock radio wouldn't charge 'newer' nano's that I use for music, but did work with the generation 1 Nano. It would play the newer ones, just not charge them... I'd wager that's what is going on with you.
I have the 3S and it was a no-go for me as well.
Schikane is offline   Reply With Quote
Old 01-24-2013, 08:39 PM   #12
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: Kansas City, MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

Quote:
Originally Posted by Loyale93 View Post

This. I had the same problem on '13 Crosstrek XV. Brand new car and USB wouldn't work. I was pissed off.

But, yes. If you flip it to the USB mode on the radio, the USB port will have power and then you can go back to radio, bluetooth, whatever.

No, you just need to flip it to USB once, then the port is turned on. After that, you can go back to whatever else.
This^

Plug phone to USB, switch head unit to USB, verify phone is charging, change head unit to whatever I want to listen to. Phone stays charging.

I just wish that you could use the iphone touchscreen while in USB mode. Hate using the stock non navi radio to sort through 100s of artists to find the one I want to listen to.

That's why I would plug in my phone, switch to USB and quickly change it to Bluetooth. This let me charge my phone and still use the phone to select songs. Pain in the ass but it worked.

That always worked with my iphone 4, have not tried with my 5 yet.
JSchell1309 is offline   Reply With Quote
Old 01-24-2013, 08:44 PM   #13
garzdos
Scooby Newbie
 
Member#: 333423
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2012 WRX Hatch
Dark Gray Metallic

Default

USB port does not charge my iphone 4S...doesn't matter what I have the stereo set to. And I don't remember the manual saying the USB port would charge a device, but I'm not totally sure and only tried with my iphone.
garzdos is offline   Reply With Quote
Old 01-24-2013, 09:39 PM   #14
Loyale93
Scooby Guru
 
Member#: 91347
Join Date: Jul 2005
Chapter/Region: NESIC
Location: Moscow, Russia
Vehicle:
'13 XV Crosstrek,
1050 Triumph Speed Triple

Default

Quote:
Originally Posted by garzdos View Post
USB port does not charge my iphone 4S...doesn't matter what I have the stereo set to. And I don't remember the manual saying the USB port would charge a device, but I'm not totally sure and only tried with my iphone.
I also have an iPhone 4S. If its not working for you, my guess is that you have a faulty USB port.
Loyale93 is offline   Reply With Quote
Old 01-24-2013, 10:08 PM   #15
garzdos
Scooby Newbie
 
Member#: 333423
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2012 WRX Hatch
Dark Gray Metallic

Default

Quote:
Originally Posted by Loyale93 View Post
I also have an iPhone 4S. If its not working for you, my guess is that you have a faulty USB port.
So if you plug your iphone 4s directly into the USB port in the console it charges your phone? No matter the settings on your stereo?
garzdos is offline   Reply With Quote
Old 01-24-2013, 10:12 PM   #16
JJL91
Scooby Newbie
 
Member#: 320380
Join Date: May 2012
Location: Buffalo NY
Vehicle:
2012 wrx
rally blue

Default

Quote:
Originally Posted by garzdos View Post

So if you plug your iphone 4s directly into the USB port in the console it charges your phone? No matter the settings on your stereo?
You must put it on USB first. It will then activate the USB function and charge your phone. Once that happens you can switch your stereo to any other function ( cd, fm and am) and your phone will continue to charge.
JJL91 is offline   Reply With Quote
Old 01-25-2013, 02:20 AM   #17
garzdos
Scooby Newbie
 
Member#: 333423
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2012 WRX Hatch
Dark Gray Metallic

Default

Quote:
Originally Posted by JJL91 View Post
You must put it on USB first. It will then activate the USB function and charge your phone. Once that happens you can switch your stereo to any other function ( cd, fm and am) and your phone will continue to charge.
That was it! I've always used the bluetooth connection for music and stuff so I never even used the USB function...

But tell me this, is there some advantage to using the USB connection with my iphone versus the bluetooth connection, other than ability to charge? Am I missing something?
garzdos is offline   Reply With Quote
Old 01-25-2013, 06:14 AM   #18
Loyale93
Scooby Guru
 
Member#: 91347
Join Date: Jul 2005
Chapter/Region: NESIC
Location: Moscow, Russia
Vehicle:
'13 XV Crosstrek,
1050 Triumph Speed Triple

Default

Quote:
Originally Posted by garzdos View Post

That was it! I've always used the bluetooth connection for music and stuff so I never even used the USB function...

But tell me this, is there some advantage to using the USB connection with my iphone versus the bluetooth connection, other than ability to charge? Am I missing something?
I use the USB port to charge because its out of the way compared to the cig lighter. But I use BT for the music playing.

To each their own. I think the USB port would be more for if you had a USB drive with all music. The equivalent of a road trip mix tape. "Hey guys, check out this mix tape!!"
Loyale93 is offline   Reply With Quote
Old 01-25-2013, 01:35 PM   #19
bigmaninjapan
Scooby Newbie
 
Member#: 299064
Join Date: Oct 2011
Chapter/Region: MWSOC
Location: Ann Arbor, MI
Vehicle:
2008 WRX Sedan (OBP)
2005 Forester 2.5XS

Default

Hopefully this will help some of you understand as to why your various iDevices may not work as expected in your cars. I have a 2008 WRX with the factory iPod (30 pin) dock and this is what I've found out.

It will not charge an iPhone4 in the stock configuration. The reason for this is because the 2008 factory 30 pin connector is wired to use the firewire pins to charge the device. Apple moved away from this in 2008-ish. I have a 5th Gen iPod Nano that also does not charge in the car. You can fix this by getting an adapter that remaps these pins. I have one of
thesethese
and it works for both my iPhone4 and my iPod Nano.

My 2008 WRX will also not control, or play any content from, my iPhone5 (using a 30 pin to lightning adapter), but it will charge so long as I'm using the adapter linked above. I actually emailed SOA about this and they said that the iPhone5 will not be supported in my car, ever. The reason for this is due to the way the head unit interfaces with the device. When Apple launched the new dock connector and various adapters for it they had to make a choice of which legacy technologies they were going to continue to support. I believe that in the 2008 WRX head unit, Subaru is using Apple's Legacy iPod Out protocol to control the device. I'm calling this legacy because Apple no longer supports that protocol over Lightning. I actually have access to the tools to confirm all of this (I'm an infotainment engineer at an OEM), but I'm lazy, its cold outside, and there is enough evidence in the reply I got back from SOA combined with a bit of google sluething around what works and doesn't work with Lightning to figure all of this out.

I've chosen to focus my time on finding an aftermarket solution that will fit my needs. I talked to some engineers at Apple (the real engineers, not the "geniuses" at the Apple store) and they've noted that in the aftermarket space, head units from Pioneer and Alpine seem to work the best. They also noted to stay away from the App Radio models in the aftermarket space due to the same sort of compatibility issues that my 08 head unit is currently experiencing.

I realize that most of this isn't terribly relevant to those of you with newer vehicles, but it isn't something I've seen discussed before. Hopefully it will provide some search fodder for people in the future.
bigmaninjapan is offline   Reply With Quote
Old 01-26-2013, 04:23 PM   #20
Wilsmick
Scooby Newbie
 
Member#: 344969
Join Date: Jan 2013
Chapter/Region: NESIC
Location: Cambridge, MA
Vehicle:
2013 WRX
DGM

Default

It's definitely not just limited to older vehicles. I just bought a 2013 WRX and I'm having the same issues every here is describing. Replacing the stock HU seems like my most likely path forward.
Wilsmick is offline   Reply With Quote
Old 03-12-2013, 08:50 AM   #21
wayfasterthanyou
Scooby Newbie
 
Member#: 303801
Join Date: Dec 2011
Location: Orlando Fl
Vehicle:
07 STI Stg2
Pearl White

Default

----/ a.aA

AA
A
A
A
A
A
AA
A

A
AA
A
A
A
A
A
A
A

A
A
wayfasterthanyou is offline   Reply With Quote
Old 03-12-2013, 05:58 PM   #22
tKbox
Scooby Newbie
 
Member#: 340490
Join Date: Dec 2012
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2013 WRX Sedan
WRB

Default

I've been able to charge my EVO LTE through the USB port since day 1. I don't even have to have the HU on and I can use Bluetooth at the same time. Maybe it's something they fixed?
tKbox is offline   Reply With Quote
Old 03-14-2013, 02:18 PM   #23
bina12834
Scooby Newbie
 
Member#: 349481
Join Date: Mar 2013
Vehicle:
2013 XV Crosstrek
Black

Default

i have the XV Crosstrek and i think (ill have to confirm) that when i plug my iphone 5 into the usb port it automatically changes over to that source.
bina12834 is offline   Reply With Quote
Old 03-15-2013, 10:26 AM   #24
bigmaninjapan
Scooby Newbie
 
Member#: 299064
Join Date: Oct 2011
Chapter/Region: MWSOC
Location: Ann Arbor, MI
Vehicle:
2008 WRX Sedan (OBP)
2005 Forester 2.5XS

Default

Quote:
Originally Posted by JSchell1309 View Post
I just wish that you could use the iphone touchscreen while in USB mode. Hate using the stock non navi radio to sort through 100s of artists to find the one I want to listen to.
Upgrade to iOS 6.1 or later. Apple removed this restriction. Works great on my iPhone4.
bigmaninjapan is offline   Reply With Quote
Old 03-15-2013, 12:43 PM   #25
jerz_subbie
Scooby Newbie
 
Member#: 221589
Join Date: Aug 2009
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2013 WRX hatch
DGM

Default

Quote:
Originally Posted by bigmaninjapan View Post
Upgrade to iOS 6.1 or later. Apple removed this restriction. Works great on my iPhone4.
Nice to know thanks. One more reason to download 6.1.2... I'm always just worried about bugs like the map and security things.
jerz_subbie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.