Welcome to the North American Subaru Impreza Owners Club Thursday September 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-25-2013, 10:04 AM   #1
What v8
Scooby Newbie
 
Member#: 254718
Join Date: Aug 2010
Default fuel pump took a dump

so the other day my car started to bog down then died, i can key it on and not hear the fuel pump anymore. I figured my fuel pump went out so i bought one off a kid locally. It had a walbro 255 in it and thats what i thought i got off the kid. after i purchased it he said it was a mgp racing fuel pump but it was still 255lph. so i swapped them out...nothing. still no fuel, and i cant hear the pump run when i turn the car on. Should i buy a new walbro 255 and try that?
* Registered users of the site do not see these ads.
What v8 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-25-2013, 10:04 AM   #2
What v8
Scooby Newbie
 
Member#: 254718
Join Date: Aug 2010
Default

Fuel system upgrades are just the fuel pump and 1000cc injectors
What v8 is offline   Reply With Quote
Old 01-25-2013, 10:51 AM   #3
white240hatch
Scooby Newbie
 
Member#: 95556
Join Date: Sep 2005
Location: savannah, ga
Vehicle:
2012 WRX 5dr
silver

Default

not sure if this helps, but my old 2002 wrx did the same thing. i spent like 10hours to diag the problem and came up with nothing. I ended up running a wire from the pump to the ignition wire going to the fuse boxs and it worked for 40k miles before i sold it. I am not sure what the correct fix would be but that was my remedy
white240hatch is offline   Reply With Quote
Old 01-25-2013, 11:37 AM   #4
tuzzio
*** Banned ***
 
Member#: 292532
Join Date: Aug 2011
Chapter/Region: NESIC
Location: Southwick, Ma
Vehicle:
05 STI
PSM

Default

Check all your fuses first.
tuzzio is offline   Reply With Quote
Old 01-25-2013, 11:43 AM   #5
the suicidal eggroll
Scooby Guru
 
Member#: 51961
Join Date: Jan 2004
Chapter/Region: RMIC
Location: Broomfield, CO
Vehicle:
2005 STi
2012 WRX

Default

Get a DMM and see if you're even getting voltage at the pump. If not, trace the system backwards until you find where you are getting voltage, and you've found your failure. Attaching the green test connectors under the dash and turning the key on will cycle the fuel pump indefinitely, letting you probe around until you find the problem.
the suicidal eggroll is offline   Reply With Quote
Old 01-25-2013, 01:47 PM   #6
What v8
Scooby Newbie
 
Member#: 254718
Join Date: Aug 2010
Default

thanks for all of thr info guys, im going to check the fuses tonight, if its not that i will diagnose it this weekend.
What v8 is offline   Reply With Quote
Old 01-27-2013, 03:05 AM   #7
What v8
Scooby Newbie
 
Member#: 254718
Join Date: Aug 2010
Default

turned out to be a fuse, anyone know why the fuse would blow? replaced it and t runs fine.
What v8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.