Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-28-2013, 10:00 AM   #1
Sillymoose
Scooby Newbie
 
Member#: 341517
Join Date: Dec 2012
Location: Canada
Vehicle:
2002 Impreza TS
Deep blue

Default Finally working again

Close to $3,100 and 2 weeks later. I finally have my first Subaru back. It's only a TS but I think it was worth the fix. I plan to drive it for a year or two to get the feel of a Subaru and see If I want to step up to a wrx after. Still need a little bit of body work and a new paint job on it though.

Here is the bill with all that had to be done, All the work was done by a Certified Subaru mechanic:





Picture of my car:


* Registered users of the site do not see these ads.
Sillymoose is offline   Reply With Quote
Old 01-28-2013, 10:13 AM   #2
Airplay355
Scooby Specialist
 
Member#: 213825
Join Date: Jun 2009
Chapter/Region: NESIC
Location: Southern Maine
Vehicle:
2011 WRX
SWP

Default

Definitely worth the save and $3100 isn't bad at all. Looks like a great car, enjoy it!
Airplay355 is offline   Reply With Quote
Old 01-28-2013, 02:47 PM   #3
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

With 200k on the clock looks like she is ready for the next 100k
aeoporta is offline   Reply With Quote
Old 01-28-2013, 02:57 PM   #4
grzydj
Scooby Specialist
 
Member#: 84984
Join Date: Apr 2005
Chapter/Region: MWSOC
Location: Sioux Falls, South Dakota
Vehicle:
2006 Impreza 2.5i 5D
'04 Toyota Tacoma TRD

Default

Looks like you had a total engine overhaul. Did you know it needed rebuilt when you bought the car?
grzydj is offline   Reply With Quote
Old 01-28-2013, 11:46 PM   #5
Sillymoose
Scooby Newbie
 
Member#: 341517
Join Date: Dec 2012
Location: Canada
Vehicle:
2002 Impreza TS
Deep blue

Default

Nope. The guy only had it for a month as a replacement car from his friend who wrecked his RS. He said it only needed a sensor. Went out driving a week later and bam overheated. Toke it to a good Subaru mechanic here and he said it was never serviced at a dealership since it was bought by the looks of it. He showed me the engine and etc. and the spark plugs didn't even have a end on them lol.
Sillymoose is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.