Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-03-2013, 05:32 AM   #1
Shadow_ Wrx
Scooby Newbie
 
Member#: 335959
Join Date: Oct 2012
Default Cusco rear strut bar wont fits..!

Hi everyone, my name is Eric, I got a 2010 Wrx hatch, and my gf bought me a cusco rear strut bar for my bday, but when I tried to put it on my car it won't fit. What happen is that there is a line
( I guess is fuel line..?) that will block the right side of strut bar bracket..? I can't get the bracket evenly, cuz the line it's in the way..!! I know the strut bar is useless, but i don't wanna sell it because its a gift from my gf, is anyone have the problem? Or how can I solve it..?
* Registered users of the site do not see these ads.
Shadow_ Wrx is offline   Reply With Quote
Old 02-03-2013, 08:46 AM   #2
bottles
Scooby Newbie
 
Member#: 311522
Join Date: Feb 2012
Chapter/Region: South East
Location: The Jungle
Vehicle:
2012 WRX
Icy Silver Metallic

Default

I've seen this issue on here before, I think you have to wiggle or move the bracket and replace after the STB install. Ill see if I can find he thread I saw it on. Can you post a pic?
bottles is offline   Reply With Quote
Old 02-03-2013, 01:46 PM   #3
Shadow_ Wrx
Scooby Newbie
 
Member#: 335959
Join Date: Oct 2012
Default

Quote:
Originally Posted by bottles View Post
I've seen this issue on here before, I think you have to wiggle or move the bracket and replace after the STB install. Ill see if I can find he thread I saw it on. Can you post a pic?
I'll post a picture later on... Thanks~!
Shadow_ Wrx is offline   Reply With Quote
Old 02-04-2013, 10:40 AM   #4
Mr Wrex
Scooby Specialist
 
Member#: 332887
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Orange County, NY
Vehicle:
2012 WRX stage 2+
DGM (sedan)

Default

Move the hose out of the way so that you can install the strut bar. Once you're done bolting it down, you will need to cut a little of your trunk mat to fit around the strut bar. After you have finished modifying that, place a piece of rubber between the strut bar and the hose to prevent them from rubbing against each other. I'm sure there's a DIY on this somewhere that has more specific instructions and recommendations.
Mr Wrex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.