Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Water/Methanol Injection, Nitrous & Intercooler Cooling

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-03-2013, 07:57 PM   #1
majik1
Scooby Newbie
 
Member#: 255841
Join Date: Aug 2010
Location: Fort Huachuca, AZ
Vehicle:
2005 WTX STi
white

Default Meth installs

Hey everyone please bare all and show me where you mounted your controllers. I was thinking about the glove box for my aem kit. But I don't know where to route the boost line either. I have the 5 gal tank and did you guys just drill holes in the trunk bottom and run bolts through? Also with the pump I don't want a lot of unnecessary vibration, just use rubber piece under it? Thanks in advance for your help!
* Registered users of the site do not see these ads.
majik1 is offline   Reply With Quote
Old 02-05-2013, 01:52 PM   #2
majik1
Scooby Newbie
 
Member#: 255841
Join Date: Aug 2010
Location: Fort Huachuca, AZ
Vehicle:
2005 WTX STi
white

Default

Nobody has a couple pics of their install?
majik1 is offline   Reply With Quote
Old 02-05-2013, 03:50 PM   #3
Mach V Dan
NASIOC Vendor
 
Member#: 12029
Join Date: Nov 2001
Chapter/Region: MAIC
Location: Sterling, VA
Default

Here's a Snow Performance setup we installed in a 2008 STI.


Early on...




Reservoir on the left, pump on the right.



Reservoir


Control box in the glove compartment.


Status and warning LEDs


Hide and seek!


Spare and tools all still fit.


Wiring

I don't have any under-hood pics because everything is hidden, so just imagine a stock engine bay, and that's what it looks like.

--Dan
Mach V
FastWRX.com
Mach V Dan is offline   Reply With Quote
Old 02-05-2013, 06:00 PM   #4
majik1
Scooby Newbie
 
Member#: 255841
Join Date: Aug 2010
Location: Fort Huachuca, AZ
Vehicle:
2005 WTX STi
white

Default

That's really sick. I have the aem 5 gal res. the orientation of the pump doesn't matter? And what did you have to do to mount the LEDs in the dash like that? Just drill a hole and glue them?
majik1 is offline   Reply With Quote
Old 02-06-2013, 08:41 AM   #5
MD04WRX
Scooby Guru
 
Member#: 72891
Join Date: Oct 2004
Chapter/Region: MAIC
Location: In the blue & hating it!
Vehicle:
2014 Molten ST
98 2.5GT -2014 XV

Default

Mounted my pump in the spare tire compartment on a (cloth covered) piece of wood. Wood is held down with the spare tire bolt. Spare won't fit over my brakes so it was the best place for it.

MD04WRX is online now   Reply With Quote
Old 02-07-2013, 08:17 AM   #6
majik1
Scooby Newbie
 
Member#: 255841
Join Date: Aug 2010
Location: Fort Huachuca, AZ
Vehicle:
2005 WTX STi
white

Default

Do you hear any loud vibrations with that?
majik1 is offline   Reply With Quote
Old 02-07-2013, 08:33 AM   #7
MD04WRX
Scooby Guru
 
Member#: 72891
Join Date: Oct 2004
Chapter/Region: MAIC
Location: In the blue & hating it!
Vehicle:
2014 Molten ST
98 2.5GT -2014 XV

Default

Quote:
Originally Posted by majik1 View Post
Do you hear any loud vibrations with that?
None, the pump comes with rubber mounts. I get no noise from the system at all. I don't even hear the pump when it's running.
MD04WRX is online now   Reply With Quote
Old 02-08-2013, 11:20 PM   #8
MWRX13
Scooby Newbie
 
Member#: 330274
Join Date: Aug 2012
Chapter/Region: Tri-State
Location: CT
Vehicle:
2013 WRX
Pearl

Default

can you turn the spray on and off? sorry new to this... interested.
MWRX13 is offline   Reply With Quote
Old 02-11-2013, 01:12 AM   #9
majik1
Scooby Newbie
 
Member#: 255841
Join Date: Aug 2010
Location: Fort Huachuca, AZ
Vehicle:
2005 WTX STi
white

Default

Depending on what tune you run, you have to have it on or off. You can wire every controller to a switch.
majik1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.